summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-03 15:17:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-03 15:17:32 +0000
commit5573e6276ffd36e9bcb4a07372b84dfa17452131 (patch)
tree6904592e5eb2d0e56cab8c3bd23077678fcb089a /net-ftp/pftpfxp
parentVersion bump for security bug #237476. Since this is basically 1.6.0.7 with o... (diff)
downloadgentoo-2-5573e6276ffd36e9bcb4a07372b84dfa17452131.tar.gz
gentoo-2-5573e6276ffd36e9bcb4a07372b84dfa17452131.tar.bz2
gentoo-2-5573e6276ffd36e9bcb4a07372b84dfa17452131.zip
Fix gcc 4.3 compile failure. Thanks to Magnus Granberg, fixes #261299
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/pftpfxp')
-rw-r--r--net-ftp/pftpfxp/ChangeLog6
-rw-r--r--net-ftp/pftpfxp/files/1.11-gcc43.patch11
-rw-r--r--net-ftp/pftpfxp/pftpfxp-1.11.ebuild6
3 files changed, 21 insertions, 2 deletions
diff --git a/net-ftp/pftpfxp/ChangeLog b/net-ftp/pftpfxp/ChangeLog
index fe8a992579ba..37d7e260c9d8 100644
--- a/net-ftp/pftpfxp/ChangeLog
+++ b/net-ftp/pftpfxp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/pftpfxp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/ChangeLog,v 1.13 2009/03/08 03:00:36 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/ChangeLog,v 1.14 2009/04/03 15:17:32 patrick Exp $
+
+ 03 Apr 2009; Patrick Lauer <patrick@gentoo.org> +files/1.11-gcc43.patch,
+ pftpfxp-1.11.ebuild:
+ Fix gcc 4.3 compile failure. Thanks to Magnus Granberg, fixes #261299
*pftpfxp-1.11 (08 Mar 2009)
diff --git a/net-ftp/pftpfxp/files/1.11-gcc43.patch b/net-ftp/pftpfxp/files/1.11-gcc43.patch
new file mode 100644
index 000000000000..d8a1c88cf419
--- /dev/null
+++ b/net-ftp/pftpfxp/files/1.11-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/tcp.cc 2003-11-08 23:00:00.000000000 +0000
++++ src/tcp.cc 2009-03-11 22:26:49.000000000 +0000
+@@ -1176,7 +1176,7 @@
+ this->size = 0;
+
+ if ((outfile_fd =
+- open(name, O_CREAT | O_TRUNC | O_RDWR | O_BINARY)) == -1) {
++ open(name, O_CREAT | O_TRUNC | O_RDWR | O_BINARY, 0644)) == -1) {
+ this->error = E_BAD_LOCALFILE;
+ return (FALSE);
+ }
diff --git a/net-ftp/pftpfxp/pftpfxp-1.11.ebuild b/net-ftp/pftpfxp/pftpfxp-1.11.ebuild
index 774061f91be8..d96ea313e985 100644
--- a/net-ftp/pftpfxp/pftpfxp-1.11.ebuild
+++ b/net-ftp/pftpfxp/pftpfxp-1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/pftpfxp-1.11.ebuild,v 1.1 2009/03/08 03:00:36 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/pftpfxp-1.11.ebuild,v 1.2 2009/04/03 15:17:32 patrick Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -16,6 +16,10 @@ IUSE="ssl"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "$FILESDIR/1.11-gcc43.patch"
+}
+
src_configure() {
#fix permissions of configure script
chmod +x configure