summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-04 06:59:40 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-04 06:59:40 +0000
commite9c1b27259143d9925f1ce57b5e658f56d1b79dc (patch)
treead01359ae2bf544e43e63ca14721ebe240f2c413 /net-fs
parentbump (diff)
downloadgentoo-2-e9c1b27259143d9925f1ce57b5e658f56d1b79dc.tar.gz
gentoo-2-e9c1b27259143d9925f1ce57b5e658f56d1b79dc.tar.bz2
gentoo-2-e9c1b27259143d9925f1ce57b5e658f56d1b79dc.zip
Version bump (#551114)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/ChangeLog9
-rw-r--r--net-fs/libnfs/libnfs-1.9.7.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-fs/libnfs/ChangeLog b/net-fs/libnfs/ChangeLog
index a6239020a3cb..20ebe428dcbe 100644
--- a/net-fs/libnfs/ChangeLog
+++ b/net-fs/libnfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/libnfs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.16 2014/11/11 11:26:16 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.17 2015/06/04 06:59:40 pacho Exp $
+
+*libnfs-1.9.7 (04 Jun 2015)
+
+ 04 Jun 2015; Pacho Ramos <pacho@gentoo.org> +libnfs-1.9.7.ebuild:
+ Version bump (#551114)
11 Nov 2014; Anthony G. Basile <blueness@gentoo.org> libnfs-1.9.5.ebuild,
libnfs-9999.ebuild:
diff --git a/net-fs/libnfs/libnfs-1.9.7.ebuild b/net-fs/libnfs/libnfs-1.9.7.ebuild
new file mode 100644
index 000000000000..9a0c42df477a
--- /dev/null
+++ b/net-fs/libnfs/libnfs-1.9.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.9.7.ebuild,v 1.1 2015/06/04 06:59:40 pacho Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
+ inherit git-2 autotools-utils
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+ inherit autotools-utils
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+}