summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-13 02:38:05 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-13 02:38:05 +0000
commit1a939c9236580ae9abac00ee4574fbc33ae9626f (patch)
treeb093fec57bc002a23d9175b7dbc86499fd49778a /net-fs/sfs
parentupdate selinux patch on findutils 4.3.4. (diff)
downloadgentoo-2-1a939c9236580ae9abac00ee4574fbc33ae9626f.tar.gz
gentoo-2-1a939c9236580ae9abac00ee4574fbc33ae9626f.tar.bz2
gentoo-2-1a939c9236580ae9abac00ee4574fbc33ae9626f.zip
CVS snapshot. Fixes GCC 4 build (bug #147269) and excessive files in / (bug
#119029). Package masked, please test. (Portage version: 2.1.2.7)
Diffstat (limited to 'net-fs/sfs')
-rw-r--r--net-fs/sfs/ChangeLog9
-rw-r--r--net-fs/sfs/files/digest-sfs-0.8.0_pre200705123
-rw-r--r--net-fs/sfs/sfs-0.8.0_pre20070512.ebuild81
3 files changed, 92 insertions, 1 deletions
diff --git a/net-fs/sfs/ChangeLog b/net-fs/sfs/ChangeLog
index d1142228baf3..2562d694b3ec 100644
--- a/net-fs/sfs/ChangeLog
+++ b/net-fs/sfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/sfs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/ChangeLog,v 1.15 2007/05/06 10:36:37 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/ChangeLog,v 1.16 2007/05/13 02:38:05 dirtyepic Exp $
+
+*sfs-0.8.0_pre20070512 (13 May 2007)
+
+ 13 May 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +sfs-0.8.0_pre20070512.ebuild:
+ CVS snapshot. Fixes GCC 4 build (bug #147269) and excessive files in / (bug
+ #119029). Package masked, please test.
06 May 2007; Marius Mauch <genone@gentoo.org> sfs-0.7.2.ebuild:
Replacing einfo with elog
diff --git a/net-fs/sfs/files/digest-sfs-0.8.0_pre20070512 b/net-fs/sfs/files/digest-sfs-0.8.0_pre20070512
new file mode 100644
index 000000000000..35e82b37588c
--- /dev/null
+++ b/net-fs/sfs/files/digest-sfs-0.8.0_pre20070512
@@ -0,0 +1,3 @@
+MD5 f828cc6d0b187fc1c022400ef4539509 sfs-0.8.0_pre20070512.tar.bz2 2072279
+RMD160 e220eb933eb7afd659d50f773e7ea84ab2a728fd sfs-0.8.0_pre20070512.tar.bz2 2072279
+SHA256 0ee1b1fea87334a2590a0c3833cad14dd547fc7fdc3d0722a3cd9ce8522b702e sfs-0.8.0_pre20070512.tar.bz2 2072279
diff --git a/net-fs/sfs/sfs-0.8.0_pre20070512.ebuild b/net-fs/sfs/sfs-0.8.0_pre20070512.ebuild
new file mode 100644
index 000000000000..554af0645254
--- /dev/null
+++ b/net-fs/sfs/sfs-0.8.0_pre20070512.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/sfs-0.8.0_pre20070512.ebuild,v 1.1 2007/05/13 02:38:05 dirtyepic Exp $
+
+inherit autotools
+
+DESCRIPTION="Self-certifying File System client and server daemons"
+HOMEPAGE="http://www.fs.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-libs/gmp-4.1
+ >=net-fs/nfs-utils-0.3.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+RDEPEND="${DEPEND}
+ >=net-nds/portmap-5b-r6"
+
+pkg_setup() {
+ # checking for NFS support *seems* like a good idea, but since
+ # nfs-utils doesn't do it, sfs won't either
+
+ # add the sfs user and group if necessary
+ enewgroup sfs
+ enewuser sfs "" "" "" sfs
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ m4 libsfs/Makefile.am.m4 > libsfs/Makefile.am
+ m4 svc/Makefile.am.m4 > svc/Makefile.am
+ eautoreconf
+
+ sed -i -e 's:\ -Werror::g' configure
+}
+
+src_compile() {
+ econf \
+ $(use_with ssl openssl /usr) \
+ --with-gmp=/usr \
+ --with-gnuld \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ insinto /etc/sfs/
+ doins ${FILESDIR}/sfsrwsd_config
+
+ dodoc AUTHORS ChangeLog NEWS \
+ README README.0.7-upgrade \
+ STANDARDS TODO
+
+ doinitd ${FILESDIR}/sfscd \
+ ${FILESDIR}/sfssd
+
+ dosym /usr/lib/${P}/newaid /usr/bin/newaid
+}
+
+pkg_postinst() {
+ elog "Execute '/etc/init.d/sfscd start' to start the SFS client,"
+ elog " or 'rc-update add sfscd default' to add it to the"
+ elog " default runlevel."
+ elog
+ elog "See the SFS documentation for server configuration."
+ elog
+ elog "Both the client and server require kernel support"
+ elog " for NFS version 3 in order to operate properly."
+ elog
+}
+
+pkg_config() {
+ einfo "Generating SFS host key..."
+ sfskey gen -P /etc/sfs/sfs_host_key
+}