summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-23 01:33:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-23 01:33:58 +0000
commitc7fa723622ba6af1dfc8424f822a8918760335fa (patch)
treefdbbdc4f7951ae93a5bddb834d77a07bee588798 /net-fs/nfs-utils
parentVersion bump (diff)
downloadgentoo-2-c7fa723622ba6af1dfc8424f822a8918760335fa.tar.gz
gentoo-2-c7fa723622ba6af1dfc8424f822a8918760335fa.tar.bz2
gentoo-2-c7fa723622ba6af1dfc8424f822a8918760335fa.zip
Fix configure script when enabling NFSv4 and Kerberos, some tests would have been skipped.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/ChangeLog9
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.2.2-nfsv4.patch13
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild114
3 files changed, 135 insertions, 1 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 0ff9111cea07..00fc5b29cd9e 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.168 2010/06/28 21:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.169 2010/07/23 01:33:58 flameeyes Exp $
+
+*nfs-utils-1.2.2-r2 (23 Jul 2010)
+
+ 23 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +nfs-utils-1.2.2-r2.ebuild, +files/nfs-utils-1.2.2-nfsv4.patch:
+ Fix configure script when enabling NFSv4 and Kerberos, some tests would
+ have been skipped.
28 Jun 2010; Mike Frysinger <vapier@gentoo.org> files/nfsmount.initd:
Fix idmapd/gssd dep calculation with nfs mounts #324725 by Михаил.
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.2.2-nfsv4.patch b/net-fs/nfs-utils/files/nfs-utils-1.2.2-nfsv4.patch
new file mode 100644
index 000000000000..cef774fe4b47
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-1.2.2-nfsv4.patch
@@ -0,0 +1,13 @@
+Index: nfs-utils-1.2.2/configure.ac
+===================================================================
+--- nfs-utils-1.2.2.orig/configure.ac
++++ nfs-utils-1.2.2/configure.ac
+@@ -81,7 +81,7 @@ AC_ARG_ENABLE(nfsv41,
+ if test "$enable_nfsv41" = yes; then
+ AC_DEFINE(NFS41_SUPPORTED, 1, [Define this if you want NFSv41 support compiled in])
+ else
+- enable_nfsv4=
++ enable_nfsv41=
+ fi
+ AC_SUBST(enable_nfsv41)
+ AM_CONDITIONAL(CONFIG_NFSV41, [test "$enable_nfsv41" = "yes"])
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..fe7d5bdc238f
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild,v 1.1 2010/07/23 01:33:58 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib autotools
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="caps ipv6 kerberos +nfsv3 +nfsv4 tcpd elibc_glibc"
+RESTRICT="test" #315573
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+DEPEND_COMMON="tcpd? ( sys-apps/tcp-wrappers )
+ caps? ( sys-libs/libcap )
+ sys-libs/e2fsprogs-libs
+ net-nds/rpcbind
+ net-libs/libtirpc
+ nfsv4? (
+ >=dev-libs/libevent-1.0b
+ >=net-libs/libnfsidmap-0.21-r1
+ kerberos? (
+ net-libs/librpcsecgss
+ net-libs/libgssglue
+ net-libs/libtirpc[kerberos]
+ app-crypt/mit-krb5
+ )
+ )"
+RDEPEND="${DEPEND_COMMON} !net-nds/portmap"
+# util-linux dep is to prevent man-page collision
+DEPEND="${DEPEND_COMMON}
+ >=sys-apps/util-linux-2.12r-r7"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
+ epatch "${FILESDIR}"/${PN}-1.1.4-no-exec.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-optional-libcap.patch #314777
+ epatch "${FILESDIR}"/${PN}-1.2.2-nfsv4.patch # fix typo
+ chmod a+x tests/t0001-statd-basic-mon-unmon.sh || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-statedir=/var/lib/nfs \
+ --enable-tirpc \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable nfsv3) \
+ $(use_enable nfsv4) \
+ $(use_enable ipv6) \
+ $(use_enable caps) \
+ $(use nfsv4 && use_enable kerberos gss || echo "--disable-gss")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ dodir /usr/lib/nfs
+ keepdir /var/lib/nfs/{sm,sm.bak}
+ mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
+ keepdir /var/lib/nfs
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
+
+ dodoc ChangeLog README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+
+ local f list="" opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list="${list} rpc.idmapd rpc.pipefs"
+ use kerberos && list="${list} rpc.gssd rpc.svcgssd"
+ fi
+ for f in nfs nfsmount rpc.statd ${list} ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
+ done
+ newconfd "${FILESDIR}"/nfs.confd nfs
+ dosed "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" /etc/conf.d/nfs #234132
+
+ # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
+ if ! use elibc_glibc ; then
+ dobin tools/rpcgen/rpcgen || die "rpcgen"
+ newdoc tools/rpcgen/README README.rpcgen
+ fi
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing.
+ # In src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. This fixes
+ # bug 30486
+ local f
+ for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
+ cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
+ done
+}