summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-30 18:24:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-30 18:24:34 +0000
commitce5048fbeb0b9f340485e88b8e50bb13473a94ad (patch)
tree34077d7f69cb6a7232db9c1248963feb1287b2c3 /net-fs/netatalk
parent*** empty log message *** (diff)
downloadgentoo-2-ce5048fbeb0b9f340485e88b8e50bb13473a94ad.tar.gz
gentoo-2-ce5048fbeb0b9f340485e88b8e50bb13473a94ad.tar.bz2
gentoo-2-ce5048fbeb0b9f340485e88b8e50bb13473a94ad.zip
*** empty log message ***
Diffstat (limited to 'net-fs/netatalk')
-rw-r--r--net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild b/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
index 75c028b0f5a4..ba6db898c11b 100644
--- a/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
+++ b/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild,v 1.3 2001/05/29 17:28:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
P=netatalk-1.4.99-0.20001108
A=${P}.tar.gz
@@ -15,24 +15,33 @@ DEPEND="virtual/glibc
tcpd? ( sys-apps/tcp-wrappers )
sys-apps/shadow
sys-devel/libtool
- sys-devel/autoconf"
+ sys-devel/autoconf
+ sys-devel/automake
+ >=sys-libs/db-3"
RDEPEND="virtual/glibc
pam? ( sys-libs/pam-0.7 )
- sys-apps/shadow"
+ sys-apps/shadow
+ >=sys-libs/db-3"
src_compile() {
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ fi
+ if [ "`use tcpd`" ] ; then
+ myconf="$myconf --with-tcp-wrappers"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --with-shadow $myconf
- try ./configure --prefix=/usr --host=${CHOST} \
- --with-pam --with-shadow --with-tcp-wrappers
-
- try make
+ try make
}
src_install() {
- cd ${S}
+
try make DESTDIR=${D} install
rm ${D}/etc/rc.d/init.d/*
insinto /etc/rc.d/init.d