summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-12-09 15:28:21 +0000
committerStuart Herbert <stuart@gentoo.org>2004-12-09 15:28:21 +0000
commit40a66aa8a3837d2213d5c91142549a64b72c5473 (patch)
treeb192002139508ab27d5783c788d6138726164427 /net-fs/ncpfs
parentremoving (diff)
downloadgentoo-2-40a66aa8a3837d2213d5c91142549a64b72c5473.tar.gz
gentoo-2-40a66aa8a3837d2213d5c91142549a64b72c5473.tar.bz2
gentoo-2-40a66aa8a3837d2213d5c91142549a64b72c5473.zip
Fix for sandbox violation
Diffstat (limited to 'net-fs/ncpfs')
-rw-r--r--net-fs/ncpfs/ChangeLog5
-rw-r--r--net-fs/ncpfs/files/ncpfs-2.2.5-php.patch16
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.5.ebuild20
3 files changed, 33 insertions, 8 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index bc62c8fe304e..1a8e65ed3bb9 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/ncpfs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.13 2004/12/01 21:28:57 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.14 2004/12/09 15:28:21 stuart Exp $
+
+ 09 Dec 2004; Stuart Herbert <stuart@gentoo.org> ncpfs-2.2.5.ebuild:
+ Fix for sandbox violation when the PHP extension is built
*ncpfs-2.2.5 (01 Dec 2004)
diff --git a/net-fs/ncpfs/files/ncpfs-2.2.5-php.patch b/net-fs/ncpfs/files/ncpfs-2.2.5-php.patch
new file mode 100644
index 000000000000..f0143b2ceebc
--- /dev/null
+++ b/net-fs/ncpfs/files/ncpfs-2.2.5-php.patch
@@ -0,0 +1,16 @@
+--- contrib/php/build/rules.mk.orig 2004-12-09 13:01:04.417854240 +0000
++++ contrib/php/build/rules.mk 2004-12-09 13:01:42.460070944 +0000
+@@ -63,10 +63,10 @@
+
+ install-modules:
+ @test -d modules && \
+- $(mkinstalldirs) $(moduledir) && \
+- echo "installing shared modules into $(moduledir)" && \
++ $(mkinstalldirs) $(DESTDIR)/$(moduledir) && \
++ echo "installing shared modules into $(DESTDIR)/$(moduledir)" && \
+ rm -f modules/*.la && \
+- cp modules/* $(moduledir) || true
++ cp modules/* $(DESTDIR)/$(moduledir) || true
+
+ include $(builddir)/.deps
+
diff --git a/net-fs/ncpfs/ncpfs-2.2.5.ebuild b/net-fs/ncpfs/ncpfs-2.2.5.ebuild
index ab6557af1601..9fe3ea1afab0 100644
--- a/net-fs/ncpfs/ncpfs-2.2.5.ebuild
+++ b/net-fs/ncpfs/ncpfs-2.2.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.5.ebuild,v 1.1 2004/12/01 21:28:57 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.5.ebuild,v 1.2 2004/12/09 15:28:21 stuart Exp $
-inherit eutils
+inherit eutils confutils
-IUSE="nls pam"
+IUSE="nls pam php"
DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
@@ -15,22 +15,28 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64 ~ppc ~ppc64"
DEPEND="nls? ( sys-devel/gettext )
- pam? ( sys-libs/pam )"
+ pam? ( sys-libs/pam )
+ php? || ( virtual/php virtual/http-php )"
src_unpack() {
unpack ${A}
# Needed because the directory in the tar.gz is not readable for anyone
chmod a+r ${S}
+
+ # add patch for PHP extension sandbox violation
+ cd ${S} || die "Unable to cd to ${S}"
+ epatch ${FILESDIR}/${PN}-2.2.5-php.patch || die "Unable to apply PHP patch"
}
src_compile() {
local myconf
- use nls || myconf="${myconf} --disable-nls"
-
- myconf="${myconf} `use_enable pam`"
+ myconf=
+ enable_extension_enable "nls" "nls" 0
+ enable_extension_enable "pam" "pam" 0
+ enable_extension_enable "php" "php" 0
econf ${myconf} || die "econf failed"
emake || die