summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-16 12:53:26 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-16 12:53:26 +0000
commitfa29d132aaf824b8231ba64c3b66cea39c8a2e4d (patch)
tree818245b210c6951e8edc559895104562a4759c15 /net-firewall
parentFix ip{,6}tables manpage generation. (diff)
downloadgentoo-2-fa29d132aaf824b8231ba64c3b66cea39c8a2e4d.tar.gz
gentoo-2-fa29d132aaf824b8231ba64c3b66cea39c8a2e4d.tar.bz2
gentoo-2-fa29d132aaf824b8231ba64c3b66cea39c8a2e4d.zip
Make initscript openrc compatible, bug #367817 wrt Robert Trace. Drop old.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog12
-rw-r--r--net-firewall/iptables/files/iptables-1.4.11.init116
-rw-r--r--net-firewall/iptables/files/iptables-1.4.8-build.patch14
-rw-r--r--net-firewall/iptables/iptables-1.4.11.1-r2.ebuild (renamed from net-firewall/iptables/iptables-1.4.11.1-r1.ebuild)8
-rw-r--r--net-firewall/iptables/iptables-1.4.11.1.ebuild83
-rw-r--r--net-firewall/iptables/iptables-1.4.3.2.ebuild50
-rw-r--r--net-firewall/iptables/iptables-1.4.7.ebuild58
-rw-r--r--net-firewall/iptables/iptables-1.4.8-r1.ebuild60
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1-r2.ebuild71
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1.ebuild59
10 files changed, 132 insertions, 399 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 0fb33d3d5407..b55a6dc554a9 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.239 2011/06/16 12:35:16 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.240 2011/06/16 12:53:26 pva Exp $
+
+*iptables-1.4.11.1-r2 (16 Jun 2011)
+
+ 16 Jun 2011; Peter Volkov <pva@gentoo.org> -iptables-1.4.3.2.ebuild,
+ -iptables-1.4.7.ebuild, -iptables-1.4.8-r1.ebuild,
+ -files/iptables-1.4.8-build.patch, -iptables-1.4.9.1.ebuild,
+ -iptables-1.4.9.1-r2.ebuild, -iptables-1.4.11.1.ebuild,
+ -iptables-1.4.11.1-r1.ebuild, +iptables-1.4.11.1-r2.ebuild,
+ +files/iptables-1.4.11.init:
+ Make initscript openrc compatible, bug #367817 wrt Robert Trace. Drop old.
*iptables-1.4.11.1-r1 (16 Jun 2011)
diff --git a/net-firewall/iptables/files/iptables-1.4.11.init b/net-firewall/iptables/files/iptables-1.4.11.init
new file mode 100644
index 000000000000..16b53ef44143
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.4.11.init
@@ -0,0 +1,116 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.4.11.init,v 1.1 2011/06/16 12:53:26 pva Exp $
+
+opts="save reload panic"
+
+iptables_name=${SVCNAME}
+if [ "${iptables_name}" != "iptables" -a "${iptables_name}" != "ip6tables" ] ; then
+ iptables_name="iptables"
+fi
+
+iptables_bin="/sbin/${iptables_name}"
+case ${iptables_name} in
+ iptables) iptables_proc="/proc/net/ip_tables_names"
+ iptables_save=${IPTABLES_SAVE};;
+ ip6tables) iptables_proc="/proc/net/ip6_tables_names"
+ iptables_save=${IP6TABLES_SAVE};;
+esac
+
+depend() {
+ before net
+ use logger
+}
+
+set_table_policy() {
+ local chains table=$1 policy=$2
+ case ${table} in
+ nat) chains="PREROUTING POSTROUTING OUTPUT";;
+ mangle) chains="PREROUTING INPUT FORWARD OUTPUT POSTROUTING";;
+ filter) chains="INPUT FORWARD OUTPUT";;
+ *) chains="";;
+ esac
+ local chain
+ for chain in ${chains} ; do
+ ${iptables_bin} -t ${table} -P ${chain} ${policy}
+ done
+}
+
+checkkernel() {
+ if [ ! -e ${iptables_proc} ] ; then
+ eerror "Your kernel lacks ${iptables_name} support, please load"
+ eerror "appropriate modules and try again."
+ return 1
+ fi
+ return 0
+}
+checkconfig() {
+ if [ ! -f ${iptables_save} ] ; then
+ eerror "Not starting ${iptables_name}. First create some rules then run:"
+ eerror "/etc/init.d/${iptables_name} save"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Loading ${iptables_name} state and starting firewall"
+ ${iptables_bin}-restore ${SAVE_RESTORE_OPTIONS} < "${iptables_save}"
+ eend $?
+}
+
+stop() {
+ if [ "${SAVE_ON_STOP}" = "yes" ] ; then
+ save || return 1
+ fi
+ checkkernel || return 1
+ ebegin "Stopping firewall"
+ local a
+ for a in $(cat ${iptables_proc}) ; do
+ set_table_policy $a ACCEPT
+
+ ${iptables_bin} -F -t $a
+ ${iptables_bin} -X -t $a
+ done
+ eend $?
+}
+
+reload() {
+ checkkernel || return 1
+ ebegin "Flushing firewall"
+ local a
+ for a in $(cat ${iptables_proc}) ; do
+ ${iptables_bin} -F -t $a
+ ${iptables_bin} -X -t $a
+ done
+ eend $?
+
+ start
+}
+
+save() {
+ ebegin "Saving ${iptables_name} state"
+ touch "${iptables_save}"
+ chmod 0600 "${iptables_save}"
+ ${iptables_bin}-save ${SAVE_RESTORE_OPTIONS} > "${iptables_save}"
+ eend $?
+}
+
+panic() {
+ checkkernel || return 1
+ if service_started ${iptables_name}; then
+ rc-service ${iptables_name} stop
+ fi
+
+ local a
+ ebegin "Dropping all packets"
+ for a in $(cat ${iptables_proc}) ; do
+ ${iptables_bin} -F -t $a
+ ${iptables_bin} -X -t $a
+
+ set_table_policy $a DROP
+ done
+ eend $?
+}
diff --git a/net-firewall/iptables/files/iptables-1.4.8-build.patch b/net-firewall/iptables/files/iptables-1.4.8-build.patch
deleted file mode 100644
index 92ea925f29d9..000000000000
--- a/net-firewall/iptables/files/iptables-1.4.8-build.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=321271
-http://marc.info/?l=netfilter&m=127468045031428&w=2
-http://marc.info/?l=netfilter&m=127468044931416&w=2
-
---- a/utils/Makefile.am
-+++ b/utils/Makefile.am
-@@ -1,5 +1,7 @@
- # -*- Makefile -*-
-
-+AM_CFLAGS = ${regular_CFLAGS} -I${top_builddir}/include -I${top_srcdir}/include
-+
- sbin_PROGRAMS = nfnl_osf
- pkgdata_DATA = pf.os
-
diff --git a/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild b/net-firewall/iptables/iptables-1.4.11.1-r2.ebuild
index 32a1d4fb8a06..3146fa282bf7 100644
--- a/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.4.11.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild,v 1.1 2011/06/16 12:35:16 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.11.1-r2.ebuild,v 1.1 2011/06/16 12:53:26 pva Exp $
EAPI="4"
@@ -24,6 +24,7 @@ COMMON_DEPEND="
DEPEND="
${COMMON_DEPEND}
virtual/os-headers
+ sys-devel/automake
"
RDEPEND="
${COMMON_DEPEND}
@@ -32,6 +33,7 @@ RDEPEND="
src_prepare() {
# Only run autotools if user patched something
epatch "${FILESDIR}/${P}-man-fixes.patch"
+ eautomake
epatch_user && eautoreconf || elibtoolize
}
@@ -70,11 +72,11 @@ src_install() {
doins include/iptables/internal.h
keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newinitd "${FILESDIR}"/${PN}-1.4.11.init iptables
newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
if use ipv6 ; then
keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newinitd "${FILESDIR}"/iptables-1.4.11.init ip6tables
newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
fi
diff --git a/net-firewall/iptables/iptables-1.4.11.1.ebuild b/net-firewall/iptables/iptables-1.4.11.1.ebuild
deleted file mode 100644
index d2723f9073d7..000000000000
--- a/net-firewall/iptables/iptables-1.4.11.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.11.1.ebuild,v 1.2 2011/06/14 02:12:35 jer Exp $
-
-EAPI="4"
-
-# Force users doing their own patches to install their own tools
-AUTOTOOLS_AUTO_DEPEND=no
-
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6 netlink"
-
-COMMON_DEPEND="
- netlink? ( net-libs/libnfnetlink )
-"
-DEPEND="
- ${COMMON_DEPEND}
- virtual/os-headers
-"
-RDEPEND="
- ${COMMON_DEPEND}
-"
-
-src_prepare() {
- # Only run autotools if user patched something
- epatch_user && eautoreconf || elibtoolize
-}
-
-src_configure() {
- sed -i \
- -e "/nfnetlink=[01]/s:=[01]:=$(use netlink && echo 1 || echo 0):" \
- configure
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static \
- $(use_enable ipv6)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc INCOMPATIBILITIES iptables/iptables.xslt
-
- # all the iptables binaries are in /sbin, so might as well
- # put these small files in with them
- into /
- dosbin iptables/iptables-apply
- dosym iptables-apply /sbin/ip6tables-apply
- doman iptables/iptables-apply.8
-
- insinto /usr/include
- doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
- insinto /usr/include/iptables
- doins include/iptables/internal.h
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
- if use ipv6 ; then
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
- fi
-
- # Move important libs to /lib
- gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
- find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
-}
diff --git a/net-firewall/iptables/iptables-1.4.3.2.ebuild b/net-firewall/iptables/iptables-1.4.3.2.ebuild
deleted file mode 100644
index 23263decc0d8..000000000000
--- a/net-firewall/iptables/iptables-1.4.3.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.3.2.ebuild,v 1.9 2009/08/31 00:29:33 ranger Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND="virtual/os-headers"
-RDEPEND=""
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch_user
-}
-
-src_compile() {
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static
- emake V=1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- insinto /usr/include
- doins include/iptables.h include/ip6tables.h || die
- insinto /usr/include/iptables
- doins include/iptables/internal.h || die
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
-}
diff --git a/net-firewall/iptables/iptables-1.4.7.ebuild b/net-firewall/iptables/iptables-1.4.7.ebuild
deleted file mode 100644
index 26a2b8f793e5..000000000000
--- a/net-firewall/iptables/iptables-1.4.7.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.7.ebuild,v 1.3 2010/12/21 13:35:21 klausman Exp $
-
-EAPI="2"
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND="virtual/os-headers"
-RDEPEND=""
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static \
- $(use_enable ipv6)
-}
-
-src_compile() {
- emake V=1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dosbin iptables-apply
- doman iptables-apply.8
- dodoc COMMIT_NOTES INCOMPATIBILITIES iptables.xslt
-
- insinto /usr/include
- doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
- insinto /usr/include/iptables
- doins include/iptables/internal.h || die
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- if use ipv6 ; then
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
- fi
-}
diff --git a/net-firewall/iptables/iptables-1.4.8-r1.ebuild b/net-firewall/iptables/iptables-1.4.8-r1.ebuild
deleted file mode 100644
index 829acc27df06..000000000000
--- a/net-firewall/iptables/iptables-1.4.8-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.8-r1.ebuild,v 1.2 2010/05/25 13:20:57 pva Exp $
-
-EAPI="2"
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND="virtual/os-headers"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-build.patch" #321271
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static \
- $(use_enable ipv6)
-}
-
-src_compile() {
- emake V=1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dosbin iptables-apply || die
- doman iptables-apply.8 || die
- dodoc INCOMPATIBILITIES iptables.xslt || die
-
- insinto /usr/include
- doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
- insinto /usr/include/iptables
- doins include/iptables/internal.h || die
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- if use ipv6 ; then
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
- fi
-}
diff --git a/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild b/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
deleted file mode 100644
index a3efb3c94907..000000000000
--- a/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild,v 1.3 2010/08/26 01:40:19 vapier Exp $
-
-EAPI="2"
-
-# Force users doing their own patches to install their own tools
-AUTOTOOLS_AUTO_DEPEND=no
-
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND="virtual/os-headers"
-RDEPEND=""
-
-src_prepare() {
- # Only run autotools if user patched something
- epatch_user && eautoreconf || elibtoolize
-
- # Keep libiptc linked against sub-libs #334503
- # We patch Makefile.in as we need libtool-2.2.10
- # for proper LDFLAGS ordering wrt LIBS
- sed -i '/$(libiptc_libiptc_la_LDFLAGS)/s:$: -Wl,--no-as-needed:' Makefile.in
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static \
- $(use_enable ipv6)
-}
-
-src_compile() {
- emake V=1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dosbin iptables-apply || die
- doman iptables-apply.8 || die
- dodoc INCOMPATIBILITIES iptables.xslt || die
-
- insinto /usr/include
- doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
- insinto /usr/include/iptables
- doins include/iptables/internal.h || die
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- if use ipv6 ; then
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
- fi
-
- # Move important libs to /lib
- gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
-}
diff --git a/net-firewall/iptables/iptables-1.4.9.1.ebuild b/net-firewall/iptables/iptables-1.4.9.1.ebuild
deleted file mode 100644
index 77bd10391291..000000000000
--- a/net-firewall/iptables/iptables-1.4.9.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1.ebuild,v 1.1 2010/08/09 08:01:56 pva Exp $
-
-EAPI="2"
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
-HOMEPAGE="http://www.iptables.org/"
-SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND="virtual/os-headers"
-RDEPEND=""
-
-src_prepare() {
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --libexecdir=/$(get_libdir) \
- --enable-devel \
- --enable-libipq \
- --enable-shared \
- --enable-static \
- $(use_enable ipv6)
-}
-
-src_compile() {
- emake V=1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dosbin iptables-apply || die
- doman iptables-apply.8 || die
- dodoc INCOMPATIBILITIES iptables.xslt || die
-
- insinto /usr/include
- doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
- insinto /usr/include/iptables
- doins include/iptables/internal.h || die
-
- keepdir /var/lib/iptables
- newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
- newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- if use ipv6 ; then
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
- fi
-}