summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-10-12 18:15:24 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-10-12 18:15:24 +0000
commite0c6ee4db1ae2c604a73e674711ff8d59563b941 (patch)
treec2ac7e601e96bf3f78413b9c767deecbbf1783a2 /net-firewall
parentVersion Bump with altered rc-file (diff)
downloadgentoo-2-e0c6ee4db1ae2c604a73e674711ff8d59563b941.tar.gz
gentoo-2-e0c6ee4db1ae2c604a73e674711ff8d59563b941.tar.bz2
gentoo-2-e0c6ee4db1ae2c604a73e674711ff8d59563b941.zip
Version Bump with altered rc-file
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-core/ChangeLog8
-rw-r--r--net-firewall/shorewall-core/files/shorewallrc_new22
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.8.2.ebuild40
3 files changed, 69 insertions, 1 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index 9cc45d59ebbc..6391d7bd875c 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.6 2012/08/15 17:49:08 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.7 2012/10/12 18:15:24 constanze Exp $
+
+*shorewall-core-4.5.8.2 (12 Oct 2012)
+
+ 12 Oct 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-core-4.5.8.2.ebuild, +files/shorewallrc_new:
+ Version Bump with altered rc-file
*shorewall-core-4.5.6.2 (15 Aug 2012)
diff --git a/net-firewall/shorewall-core/files/shorewallrc_new b/net-firewall/shorewall-core/files/shorewallrc_new
new file mode 100644
index 000000000000..06253dc2b8cb
--- /dev/null
+++ b/net-firewall/shorewall-core/files/shorewallrc_new
@@ -0,0 +1,22 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD= #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=etc/init.d #Directory where SysV init scripts are installed.
+INITFILE=$PRODUCT #Name of the product's installed SysV init script
+INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/$PRODUCT #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.8.2.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.8.2.ebuild
new file mode 100644
index 000000000000..224e173b05e8
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.8.2.ebuild,v 1.1 2012/10/12 18:15:24 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="shorewall-${MY_PV_BASE}"
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ !<net-firewall/shorewall-4.5.0.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ default
+}