summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-06-17 12:50:57 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-06-17 12:50:57 +0000
commitc8a4392178b5a2b939332e9c6354de9663e93146 (patch)
treeee3e4f4c990bda0e38458d489fdd409bd36e62f7 /net-firewall
parentVersion bump (adds py3k support). (diff)
downloadgentoo-2-c8a4392178b5a2b939332e9c6354de9663e93146.tar.gz
gentoo-2-c8a4392178b5a2b939332e9c6354de9663e93146.tar.bz2
gentoo-2-c8a4392178b5a2b939332e9c6354de9663e93146.zip
Version bump (bug #503376), which mostly solves py3k-compat (bug #459198).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/ChangeLog10
-rw-r--r--net-firewall/firewalld/files/firewalld-0.3.10-py3k-compat.patch24
-rw-r--r--net-firewall/firewalld/firewalld-0.3.10.ebuild99
3 files changed, 131 insertions, 2 deletions
diff --git a/net-firewall/firewalld/ChangeLog b/net-firewall/firewalld/ChangeLog
index 27c46e47151b..90bebf46283a 100644
--- a/net-firewall/firewalld/ChangeLog
+++ b/net-firewall/firewalld/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/firewalld
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.13 2013/02/24 11:29:56 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.14 2014/06/17 12:50:57 dev-zero Exp $
+
+*firewalld-0.3.10 (17 Jun 2014)
+
+ 17 Jun 2014; Tiziano Müller <dev-zero@gentoo.org>
+ +files/firewalld-0.3.10-py3k-compat.patch, +firewalld-0.3.10.ebuild:
+ Version bump (bug #503376), which mostly solves py3k-compat (bug #459198).
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> firewalld-0.2.9-r1.ebuild:
Stable for x86, wrt bug #458688
diff --git a/net-firewall/firewalld/files/firewalld-0.3.10-py3k-compat.patch b/net-firewall/firewalld/files/firewalld-0.3.10-py3k-compat.patch
new file mode 100644
index 000000000000..e91590f1cff6
--- /dev/null
+++ b/net-firewall/firewalld/files/firewalld-0.3.10-py3k-compat.patch
@@ -0,0 +1,24 @@
+diff --git a/src/firewall/core/io/direct.py b/src/firewall/core/io/direct.py
+index b698e4c..6b80201 100644
+--- a/src/firewall/core/io/direct.py
++++ b/src/firewall/core/io/direct.py
+@@ -295,8 +295,8 @@ class Direct(IO_Object):
+ if len(self.passthroughs[ipv]) == 0:
+ del self.passthroughs[ipv]
+ else:
+- raise ValueError, "Passthrough '%s' for ipv '%s'" % \
+- ("',".join(args), ipv) + "not in list"
++ raise ValueError("Passthrough '%s' for ipv '%s'" % \
++ ("',".join(args), ipv) + "not in list")
+
+ def query_passthrough(self, ipv, args):
+ return (ipv in self.passthroughs and args in self.passthroughs[ipv])
+@@ -305,7 +305,7 @@ class Direct(IO_Object):
+ if ipv in self.passthroughs:
+ return self.passthroughs[ipv]
+ else:
+- raise ValueError, "No passthroughs for ipv '%s'" % (ipv)
++ raise ValueError("No passthroughs for ipv '%s'" % (ipv))
+
+ def get_all_passthroughs(self):
+ return self.passthroughs
diff --git a/net-firewall/firewalld/firewalld-0.3.10.ebuild b/net-firewall/firewalld/firewalld-0.3.10.ebuild
new file mode 100644
index 000000000000..8fd61583cfd7
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.3.10.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/firewalld-0.3.10.ebuild,v 1.1 2014/06/17 12:50:57 dev-zero Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+#BACKPORTS=190680ba
+
+inherit autotools eutils gnome2-utils python-r1 systemd multilib bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://fedorahosted.org/firewalld"
+SRC_URI="https://fedorahosted.org/released/firewalld/${P}.tar.bz2
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch "${FILESDIR}/${P}-py3k-compat.patch"
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_export_best
+
+ econf \
+ --enable-systemd \
+ "$(systemd_with_unitdir 'systemd-unitdir')" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ # manually split up the installation to avoid "file already exists" errors
+ emake -C config DESTDIR="${ED}" install
+ emake -C po DESTDIR="${ED}" install
+ emake -C shell-completion DESTDIR="${ED}" install
+
+ install_python() {
+ emake -C src DESTDIR="${ED}" pythondir="$(python_get_sitedir)" install
+ python_optimize
+ }
+ python_foreach_impl install_python
+
+ python_replicate_script "${ED}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
+ python_replicate_script "${ED}/usr/sbin/firewalld"
+
+ # Get rid of junk
+ rm -f "${ED}/etc/rc.d/init.d/firewalld"
+ rm -f "${ED}/etc/sysconfig/firewalld"
+ rm -rf "${ED}/etc/rc.d/"
+ rm -rf "${ED}/etc/sysconfig/"
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -f "${ED}/usr/bin/firewall-applet"
+ rm -f "${ED}/usr/bin/firewall-config"
+ rm -rf "${ED}/usr/share/icons"
+ rm -rf "${ED}/usr/share/applications"
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}