summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-01-11 20:08:59 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-01-11 20:08:59 +0000
commita5f85e78be832120127c93b8019877a3c38d5388 (patch)
treeeb2634742e6e6732b1b2cc6cc9b15526865cbd94 /net-firewall
parentVersion Bump (diff)
downloadgentoo-2-a5f85e78be832120127c93b8019877a3c38d5388.tar.gz
gentoo-2-a5f85e78be832120127c93b8019877a3c38d5388.tar.bz2
gentoo-2-a5f85e78be832120127c93b8019877a3c38d5388.zip
Version Bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/shorewall6-4.4.15.3.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index 6387929e2b28..51400cb2aeab 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.21 2011/01/04 14:26:53 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.22 2011/01/11 20:08:59 constanze Exp $
+
+*shorewall6-4.4.15.3 (11 Jan 2011)
+
+ 11 Jan 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.4.15.3.ebuild:
+ Version bump.
04 Jan 2011; Michael Weber <xmw@gentoo.org> shorewall6-4.2.11-r1.ebuild,
shorewall6-4.4.2.ebuild, shorewall6-4.4.10.ebuild,
diff --git a/net-firewall/shorewall6/shorewall6-4.4.15.3.ebuild b/net-firewall/shorewall6/shorewall6-4.4.15.3.ebuild
new file mode 100644
index 000000000000..ca5c6cb80a86
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.4.15.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.4.15.3.ebuild,v 1.1 2011/01/11 20:08:59 constanze Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10+ and must emerge dev-perl/Socket6."
+}