summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-01-09 20:50:50 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-01-09 20:50:50 +0000
commit97696a3a8eee6cd65dd1248fcca46a9b9c6cf357 (patch)
treed32fe3ca245055fe159fa9ec60d2fc592f0d8a3b /net-firewall
parentKeyword ~mips and ~x86 (diff)
downloadgentoo-2-97696a3a8eee6cd65dd1248fcca46a9b9c6cf357.tar.gz
gentoo-2-97696a3a8eee6cd65dd1248fcca46a9b9c6cf357.tar.bz2
gentoo-2-97696a3a8eee6cd65dd1248fcca46a9b9c6cf357.zip
Version bump: add git snapshot that runs correctly on recent kernels, wrt bug #535820
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog9
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.0.1_p20150109.ebuild83
2 files changed, 91 insertions, 1 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index a46396441e13..86f5b3088ba6 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.20 2015/01/09 20:40:12 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.21 2015/01/09 20:50:50 pinkbyte Exp $
+
+*ipt_netflow-2.0.1_p20150109 (09 Jan 2015)
+
+ 09 Jan 2015; Sergey Popov <pinkbyte@gentoo.org>
+ +ipt_netflow-2.0.1_p20150109.ebuild:
+ Version bump: add git snapshot that runs correctly on recent kernels, wrt bug
+ #535820
09 Jan 2015; Sergey Popov <pinkbyte@gentoo.org> -ipt_netflow-1.8-r4.ebuild,
-files/ipt_netflow-1.8-configure.patch,
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.0.1_p20150109.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.0.1_p20150109.ebuild
new file mode 100644
index 000000000000..92c461d95322
--- /dev/null
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.0.1_p20150109.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0.1_p20150109.ebuild,v 1.1 2015/01/09 20:50:50 pinkbyte Exp $
+
+EAPI=5
+inherit eutils linux-info linux-mod multilib toolchain-funcs
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug"
+
+RDEPEND="
+ net-firewall/iptables
+"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ virtual/pkgconfig
+"
+
+# set S before MODULE_NAMES
+S="${WORKDIR}/${PN/_/-}-${PV}"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
+
+IPT_LIB="/usr/$(get_libdir)/xtables"
+
+pkg_setup() {
+ local CONFIG_CHECK="~IP_NF_IPTABLES"
+ use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:make -C:$(MAKE) -C:g' \
+ -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ Makefile.in || die
+
+ # bug #455984
+ epatch "${FILESDIR}/${PN}-2.0-configure.patch"
+
+ epatch_user
+}
+
+do_conf() {
+ echo ./configure $*
+ ./configure $* ${EXTRA_ECONF} || die 'configure failed'
+}
+
+src_configure() {
+ local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+ # this configure script is not based on autotools
+ # ipt-src need to be defined, see bug #455984
+ do_conf \
+ --disable-dkms \
+ --disable-snmp-agent \
+ --ipt-lib="${IPT_LIB}" \
+ --ipt-src="/usr/" \
+ --ipt-ver="${IPT_VERSION}" \
+ --kdir="${KV_DIR}" \
+ --kver="${KV_FULL}" \
+ $(use debug && echo '--enable-debugfs')
+}
+
+src_compile() {
+ emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
+}
+
+src_install() {
+ linux-mod_src_install
+ exeinto "${IPT_LIB}"
+ doexe libipt_NETFLOW.so
+ doheader ipt_NETFLOW.h
+ dodoc README*
+}