summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-10 09:56:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-10 09:56:58 +0000
commit610511e51d599c8823530507202a4aa3b3212ac2 (patch)
treec054db73c779fee88507fb46b260836eef2ea2e3 /net-firewall
parentUpdate m4 macro. (diff)
downloadgentoo-2-610511e51d599c8823530507202a4aa3b3212ac2.tar.gz
gentoo-2-610511e51d599c8823530507202a4aa3b3212ac2.tar.bz2
gentoo-2-610511e51d599c8823530507202a4aa3b3212ac2.zip
Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.0.51.16)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/ChangeLog10
-rw-r--r--net-firewall/ipset/Manifest2
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.1.0.200501191
-rw-r--r--net-firewall/ipset/ipset-2.1.0.20050119.ebuild65
-rw-r--r--net-firewall/ipset/metadata.xml8
5 files changed, 86 insertions, 0 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
new file mode 100644
index 000000000000..ea51541c837f
--- /dev/null
+++ b/net-firewall/ipset/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-firewall/ipset
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.1 2005/03/10 09:56:57 robbat2 Exp $
+
+*ipset-2.1.0.20050119 (10 Mar 2005)
+
+ 10 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +ipset-2.1.0.20050119.ebuild:
+ Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>.
+
diff --git a/net-firewall/ipset/Manifest b/net-firewall/ipset/Manifest
new file mode 100644
index 000000000000..6e1d9c2a374f
--- /dev/null
+++ b/net-firewall/ipset/Manifest
@@ -0,0 +1,2 @@
+MD5 edb26346a11067ff6206db9f21cda327 ipset-2.1.0.20050119.ebuild 1596
+MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119 72
diff --git a/net-firewall/ipset/files/digest-ipset-2.1.0.20050119 b/net-firewall/ipset/files/digest-ipset-2.1.0.20050119
new file mode 100644
index 000000000000..68db10cd589a
--- /dev/null
+++ b/net-firewall/ipset/files/digest-ipset-2.1.0.20050119
@@ -0,0 +1 @@
+MD5 9f1b9c36d37eb8371c83b5610362d16d ipset-2.1.0-20050119.tar.bz2 23821
diff --git a/net-firewall/ipset/ipset-2.1.0.20050119.ebuild b/net-firewall/ipset/ipset-2.1.0.20050119.ebuild
new file mode 100644
index 000000000000..6759f7614b13
--- /dev/null
+++ b/net-firewall/ipset/ipset-2.1.0.20050119.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.1.0.20050119.ebuild,v 1.1 2005/03/10 09:56:57 robbat2 Exp $
+
+inherit eutils flag-o-matic versionator
+
+MY_PV="$(replace_version_separator 3 '-' )"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="IPset tool for iptables, successor to ippool."
+HOMEPAGE="http://people.netfilter.org/kadlec/ipset/"
+SRC_URI="${HOMEPAGE}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=net-firewall/iptables-1.3*"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ ewarn "If your kernel sources do not contain the IPset functionality,"
+ ewarn "this package may file to compile."
+}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ export myconf
+}
+
+src_compile() {
+ src_defs
+
+ # for some reason, it doesn't behave right if this is skipped
+ replace-flags -O0 -O2
+ if [ -z `get-flag O` ]; then
+ append-flags -O2
+ fi
+
+ # see iptables ebuild, as this code links against it
+ filter-flags "-fstack-protector"
+
+ if [ -L ${ROOT}/usr/src/linux -o -d ${ROOT}/usr/src/linux ]; then
+ check_KV
+ else
+ die "ipset requires your patched kernel source to be at /usr/src/linux!"
+ fi
+
+ # now build it
+ emake COPT_FLAGS="${CFLAGS}" ${myconf} \
+ KERNEL_DIR=/usr/src/linux \
+ || die "failed to build"
+}
+
+src_install() {
+ src_defs
+ emake DESTDIR="${D}" ${myconf} \
+ KERNEL_DIR=/usr/src/linux \
+ install || die "failed to package"
+}
diff --git a/net-firewall/ipset/metadata.xml b/net-firewall/ipset/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/net-firewall/ipset/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>