summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-05-03 22:48:54 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-05-03 22:48:54 +0000
commit15c7af400fcd4b64231337303e6dc9d56cce5867 (patch)
treeb1d2360d6b1a62c8073aba18373c9261622d0126 /net-firewall
parentBump ebuild + stable x86, bug 90595. (diff)
downloadgentoo-2-15c7af400fcd4b64231337303e6dc9d56cce5867.tar.gz
gentoo-2-15c7af400fcd4b64231337303e6dc9d56cce5867.tar.bz2
gentoo-2-15c7af400fcd4b64231337303e6dc9d56cce5867.zip
Multilib fixes.
(Portage version: 2.0.51.21)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog5
-rw-r--r--net-firewall/iptables/Manifest4
-rw-r--r--net-firewall/iptables/iptables-1.3.1-r3.ebuild8
3 files changed, 10 insertions, 7 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index b30120529fd7..2e5edd3a62f8 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.67 2005/05/03 14:43:25 omkhar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.68 2005/05/03 22:48:54 herbs Exp $
+
+ 03 May 2005; Herbie Hopkins <herbs@gentoo.org> iptables-1.3.1-r3.ebuild:
+ Multilib fixes.
03 May 2005; Omkhar Arasaratnam <omkhar@gentoo.org>
iptables-1.3.1-r3.ebuild:
diff --git a/net-firewall/iptables/Manifest b/net-firewall/iptables/Manifest
index a8977579ca93..21ef0c18945b 100644
--- a/net-firewall/iptables/Manifest
+++ b/net-firewall/iptables/Manifest
@@ -1,12 +1,12 @@
MD5 cdf47a369303ed0da3bb2f6888dc1aa8 iptables-1.2.7a-r3.ebuild 1982
-MD5 3f606fa23b084a33172afb53e20b97b0 iptables-1.3.1-r3.ebuild 5560
+MD5 5284224c173b0c9e15c6c920521eff83 iptables-1.3.1-r3.ebuild 5600
MD5 c3b7afaef1230c12fc9afbfadd53472b iptables-1.2.11-r3.ebuild 5514
MD5 e2158f065e3c8a603eb424a8ff613e4e iptables-1.2.9-r4.ebuild 5435
MD5 20d154d66f67db6a04208bda433d9823 iptables-1.2.9.ebuild 2805
MD5 85308a3a1261a0d23035c6869c5b922c iptables-1.3.1-r2.ebuild 5542
MD5 d8db7c69648295e17016d8bbe4c55c07 iptables-1.2.9-r1.ebuild 3526
MD5 5c9fe97964cdb981c75f43f20ba48c15 iptables-1.2.11-r2.ebuild 5379
-MD5 b8280d2ea79ed75f0e02ad3351fb57d7 ChangeLog 17419
+MD5 bfade3b92c260f0011c9b77cc0f00bff ChangeLog 17513
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
MD5 f876be872ec78bc824f2503059338d8d files/iptables.confd 382
MD5 6fcbeff4b5ce0f79f66265cb8af3d55f files/ip6tables.init 2020
diff --git a/net-firewall/iptables/iptables-1.3.1-r3.ebuild b/net-firewall/iptables/iptables-1.3.1-r3.ebuild
index 0a33bf1ff8d5..282621ce59db 100644
--- a/net-firewall/iptables/iptables-1.3.1-r3.ebuild
+++ b/net-firewall/iptables/iptables-1.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.1-r3.ebuild,v 1.5 2005/05/03 14:43:25 omkhar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.1-r3.ebuild,v 1.6 2005/05/03 22:48:54 herbs Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -87,7 +87,7 @@ src_unpack() {
src_defs() {
# these are used in both of src_compile and src_install
myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} LIBDIR=/$(get_libdir)"
myconf="${myconf} BINDIR=/sbin"
myconf="${myconf} MANDIR=/usr/share/man"
myconf="${myconf} INCDIR=/usr/include"
@@ -142,8 +142,8 @@ src_install() {
install install-devel || die
fi
- dodir /usr/lib
- mv -f ${D}/lib/*.a ${D}/usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f ${D}/$(get_libdir)/*.a ${D}/usr/$(get_libdir)
keepdir /var/lib/iptables
newinitd ${FILESDIR}/${PN}-1.2.9-r1.init iptables