summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-04-12 07:00:30 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-04-12 07:00:30 +0000
commit58cb62181873b776ef1972ddd033555725bfec20 (patch)
tree23cc0a459cbe8a8ff9b8b1607293dcd94cbe7ec2 /net-firewall/ipsec-tools
parentclean older ebuilds (Manifest recommit) (diff)
downloadgentoo-2-58cb62181873b776ef1972ddd033555725bfec20.tar.gz
gentoo-2-58cb62181873b776ef1972ddd033555725bfec20.tar.bz2
gentoo-2-58cb62181873b776ef1972ddd033555725bfec20.zip
Changed the initialization scripts to flush the tables when racoon is stopped; closes bug #47089.
Diffstat (limited to 'net-firewall/ipsec-tools')
-rw-r--r--net-firewall/ipsec-tools/ChangeLog7
-rw-r--r--net-firewall/ipsec-tools/files/racoon.conf.d12
-rw-r--r--net-firewall/ipsec-tools/files/racoon.init.d6
3 files changed, 21 insertions, 4 deletions
diff --git a/net-firewall/ipsec-tools/ChangeLog b/net-firewall/ipsec-tools/ChangeLog
index e2aa5562fc86..c81a55341119 100644
--- a/net-firewall/ipsec-tools/ChangeLog
+++ b/net-firewall/ipsec-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipsec-tools
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.5 2004/04/10 03:56:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.6 2004/04/12 07:00:30 plasmaroo Exp $
+
+ 12 Apr 2004; <plasmaroo@gentoo.org> files/racoon.conf.d,
+ files/racoon.init.d:
+ Changed the initialization scripts to flush the tables when racoon is
+ stopped - closes bug #47089.
09 Apr 2004; Jason Wever <weeve@gentoo.org> ipsec-tools-0.2.5.ebuild:
It only takes a ~sparc, to get an ipsec tunnel going...
diff --git a/net-firewall/ipsec-tools/files/racoon.conf.d b/net-firewall/ipsec-tools/files/racoon.conf.d
index 8d2f2c3483b1..9ab7b085d60a 100644
--- a/net-firewall/ipsec-tools/files/racoon.conf.d
+++ b/net-firewall/ipsec-tools/files/racoon.conf.d
@@ -1,13 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/files/racoon.conf.d,v 1.1 2003/12/16 18:04:33 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/files/racoon.conf.d,v 1.2 2004/04/12 07:00:30 plasmaroo Exp $
# Config file for /etc/init.d/racoon
-# see man pages for racoon or run `racoon --help`
-# for valid cmdline options
+# See the manual pages for racoon or run `racoon --help`
+# for valid command-line options
+
RACOON_OPTS="-4"
RACOON_CONF="/etc/racoon/racoon.conf"
RACOON_PSK_FILE="/etc/racoon/psk.txt"
SETKEY_CONF="/etc/ipsec.conf"
+
+# Comment or remove the following if you don't want the policy tables
+# to be flushed when racoon is stopped.
+
+RACOON_RESET_TABLES="true"
diff --git a/net-firewall/ipsec-tools/files/racoon.init.d b/net-firewall/ipsec-tools/files/racoon.init.d
index 53ee6d00cbaf..ea0a05eb3320 100644
--- a/net-firewall/ipsec-tools/files/racoon.init.d
+++ b/net-firewall/ipsec-tools/files/racoon.init.d
@@ -49,4 +49,10 @@ stop() {
ebegin "Stopping racoon"
kill `cat /var/run/racoon.pid`
eend $?
+ if [ -n "${RACOON_RESET_TABLES}" ]; then
+ ebegin "Flushing policy entries"
+ /usr/sbin/setkey -F
+ /usr/sbin/setkey -FP
+ eend $?
+ fi
}