summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-03-10 11:11:19 +0000
committerAlin Năstac <mrness@gentoo.org>2007-03-10 11:11:19 +0000
commit82b5bb7c25889ca96515a8f37a64c284a7efa660 (patch)
tree2167576eb8880fb03355f1457c7bb3704ab6a733 /net-firewall/ipp2p
parentMIPS love. (diff)
downloadgentoo-2-82b5bb7c25889ca96515a8f37a64c284a7efa660.tar.gz
gentoo-2-82b5bb7c25889ca96515a8f37a64c284a7efa660.tar.bz2
gentoo-2-82b5bb7c25889ca96515a8f37a64c284a7efa660.zip
Remove $ROOT from src_compile (#168039).
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog5
-rw-r--r--net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index 87c652762537..5e3a1f077df4 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.26 2007/01/16 17:12:14 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.27 2007/03/10 11:11:19 mrness Exp $
+
+ 10 Mar 2007; Alin Năstac <mrness@gentoo.org> ipp2p-0.8.2-r2.ebuild:
+ Remove $ROOT from src_compile (#168039).
16 Jan 2007; Alin Năstac <mrness@gentoo.org> -ipp2p-0.8.0.ebuild,
-ipp2p-0.8.2.ebuild, -ipp2p-0.8.2-r1.ebuild, ipp2p-0.8.2-r2.ebuild:
diff --git a/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild b/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild
index bc26548a92da..6fe2f7c9fcf7 100644
--- a/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild
+++ b/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild,v 1.5 2007/01/16 17:12:14 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2-r2.ebuild,v 1.6 2007/03/10 11:11:19 mrness Exp $
inherit linux-mod eutils
@@ -41,15 +41,15 @@ src_unpack() {
}
src_compile() {
- local IPTABLES_VERSION="$("${ROOT}"/sbin/iptables --version | cut -f2 -dv)"
+ local IPTABLES_VERSION="$(/sbin/iptables --version | cut -f2 -dv)"
emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
- IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so \
+ IPTABLES_SRC="/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so \
|| die "Failed to build iptables module"
local myARCH="${ARCH}"
ARCH="$(tc-arch-kernel)"
emake KERNEL_SRC="${KV_DIR}" \
- IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" \
+ IPTABLES_SRC="/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" \
|| die "Failed to build kernel module."
ARCH="${myARCH}"
}