summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-11-11 18:18:46 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-11-11 18:18:46 +0000
commit965ec5bd7ccb926e96e55b539c7de23ced2ef567 (patch)
tree1e3615eb1b34ca0c1e7d329f1a367aedb9bfe50f /net-dns
parentFix for implict declarations and underlinking (diff)
downloadgentoo-2-965ec5bd7ccb926e96e55b539c7de23ced2ef567.tar.gz
gentoo-2-965ec5bd7ccb926e96e55b539c7de23ced2ef567.tar.bz2
gentoo-2-965ec5bd7ccb926e96e55b539c7de23ced2ef567.zip
Fix HOMEPAGE. QA fixes. Revision bump, added a definition to enable the sigchase feature, bug 344029. Merged my latest changes into bind-tools-9.4.3_p5-r1.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/ChangeLog15
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.3_p5-r1.ebuild99
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild9
-rw-r--r--net-dns/bind-tools/bind-tools-9.6.2_p2-r1.ebuild101
-rw-r--r--net-dns/bind-tools/bind-tools-9.7.1-r1.ebuild (renamed from net-dns/bind-tools/bind-tools-9.7.2_p2.ebuild)8
-rw-r--r--net-dns/bind-tools/bind-tools-9.7.2_p2-r1.ebuild98
6 files changed, 322 insertions, 8 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index 3324ef7d03a3..a35c6f9a3e90 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-dns/bind-tools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.169 2010/11/06 17:47:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.170 2010/11/11 18:18:46 idl0r Exp $
+
+*bind-tools-9.7.2_p2-r1 (11 Nov 2010)
+*bind-tools-9.7.1-r1 (11 Nov 2010)
+*bind-tools-9.6.2_p2-r1 (11 Nov 2010)
+*bind-tools-9.4.3_p5-r1 (11 Nov 2010)
+
+ 11 Nov 2010; Christian Ruppert <idl0r@gentoo.org> bind-tools-9.4.3_p5.ebuild,
+ +bind-tools-9.4.3_p5-r1.ebuild, +bind-tools-9.6.2_p2-r1.ebuild,
+ +bind-tools-9.7.1-r1.ebuild, -bind-tools-9.7.2_p2.ebuild,
+ +bind-tools-9.7.2_p2-r1.ebuild:
+ Fix HOMEPAGE. QA fixes. Revision bump, added a definition to enable the
+ sigchase feature, bug 344029. Merged my latest changes into
+ bind-tools-9.4.3_p5-r1.
06 Nov 2010; Markus Meier <maekke@gentoo.org> bind-tools-9.7.1.ebuild:
arm stable, bug #337638
diff --git a/net-dns/bind-tools/bind-tools-9.4.3_p5-r1.ebuild b/net-dns/bind-tools/bind-tools-9.4.3_p5-r1.ebuild
new file mode 100644
index 000000000000..ed185357c183
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.4.3_p5-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p5-r1.ebuild,v 1.1 2010/11/11 18:18:46 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils autotools flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc idn ipv6 ssl urandom"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ idn? (
+ || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug 122597
+ use idn && {
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd "${S}"
+ }
+
+ # bug 231247
+ epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch
+
+ # bug 278364 (workaround)
+ epatch "${FILESDIR}/${PN}-9.6.1-parallel.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 344029
+ append-cppflags "-DDIG_SIGCHASE"
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(use_with ssl openssl) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ emake -C lib/ || die "emake lib failed"
+ emake -C bin/dig/ || die "emake bin/dig failed"
+ emake -C bin/nsupdate/ || die "emake bin/nsupdate failed"
+ emake -C bin/dnssec/ || die "emake bin/dnssec failed"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ || die
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman {dig,host,nslookup}.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ if use doc; then
+ dohtml nsupdate.html || die
+ fi
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ if use doc; then
+ dohtml dnssec-keygen.html || die
+ fi
+}
diff --git a/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild b/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild
index 20f100e9c769..65928af97f3b 100644
--- a/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild,v 1.6 2010/09/28 15:00:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p5.ebuild,v 1.7 2010/11/11 18:18:46 idl0r Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
MY_PN=${PN//-tools}
MY_PV=${PV/_p/-P}
MY_P="${MY_PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
-HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+HOMEPAGE="http://www.isc.org/software/bind"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
LICENSE="as-is"
@@ -18,7 +18,8 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="idn ipv6"
DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv )
- net-dns/idnkit )"
+ net-dns/idnkit )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A} || die
diff --git a/net-dns/bind-tools/bind-tools-9.6.2_p2-r1.ebuild b/net-dns/bind-tools/bind-tools-9.6.2_p2-r1.ebuild
new file mode 100644
index 000000000000..ecc9d53db5de
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.6.2_p2-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.6.2_p2-r1.ebuild,v 1.1 2010/11/11 18:18:46 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils autotools flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc idn ipv6 ssl urandom xml"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ xml? ( dev-libs/libxml2 )
+ idn? (
+ || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug 122597
+ use idn && {
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd "${S}"
+ }
+
+ # bug 231247
+ epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch
+
+ # bug 278364 (workaround)
+ epatch "${FILESDIR}/${PN}-9.6.1-parallel.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 344029
+ append-cppflags "-DDIG_SIGCHASE"
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(use_with ssl openssl) \
+ $(use_with xml libxml2) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ emake -C lib/ || die "emake lib failed"
+ emake -C bin/dig/ || die "emake bin/dig failed"
+ emake -C bin/nsupdate/ || die "emake bin/nsupdate failed"
+ emake -C bin/dnssec/ || die "emake bin/dnssec failed"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ || die
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman {dig,host,nslookup}.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ if use doc; then
+ dohtml nsupdate.html || die
+ fi
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ if use doc; then
+ dohtml dnssec-keygen.html || die
+ fi
+}
diff --git a/net-dns/bind-tools/bind-tools-9.7.2_p2.ebuild b/net-dns/bind-tools/bind-tools-9.7.1-r1.ebuild
index 415a4d83b92f..62b874191298 100644
--- a/net-dns/bind-tools/bind-tools-9.7.2_p2.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.7.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.7.2_p2.ebuild,v 1.1 2010/10/05 15:47:56 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.7.1-r1.ebuild,v 1.1 2010/11/11 18:18:46 idl0r Exp $
EAPI="3"
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
MY_PN=${PN//-tools}
MY_PV=${PV/_p/-P}
@@ -54,6 +54,9 @@ src_configure() {
myconf="${myconf} --with-randomdev=/dev/random"
fi
+ # bug 344029
+ append-cppflags "-DDIG_SIGCHASE"
+
econf \
$(use_enable ipv6) \
$(use_with idn) \
@@ -89,7 +92,6 @@ src_install() {
cd "${S}"/bin/dnssec
dobin dnssec-keygen || die
doman dnssec-keygen.8 || die
-
if use doc; then
dohtml dnssec-keygen.html || die
fi
diff --git a/net-dns/bind-tools/bind-tools-9.7.2_p2-r1.ebuild b/net-dns/bind-tools/bind-tools-9.7.2_p2-r1.ebuild
new file mode 100644
index 000000000000..d70ec9a4b641
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.7.2_p2-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.7.2_p2-r1.ebuild,v 1.1 2010/11/11 18:18:46 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils autotools flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc idn ipv6 ssl urandom xml"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ xml? ( dev-libs/libxml2 )
+ idn? (
+ || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug 122597
+ use idn && {
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd "${S}"
+ }
+
+ # bug 231247
+ epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 344029
+ append-cppflags "-DDIG_SIGCHASE"
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(use_with ssl openssl) \
+ $(use_with xml libxml2) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ emake -C lib/ || die "emake lib failed"
+ emake -C bin/dig/ || die "emake bin/dig failed"
+ emake -C bin/nsupdate/ || die "emake bin/nsupdate failed"
+ emake -C bin/dnssec/ || die "emake bin/dnssec failed"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ || die
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman {dig,host,nslookup}.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ if use doc; then
+ dohtml nsupdate.html || die
+ fi
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ if use doc; then
+ dohtml dnssec-keygen.html || die
+ fi
+}