summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2014-04-26 19:26:54 +0000
committerWolfram Schlich <wschlich@gentoo.org>2014-04-26 19:26:54 +0000
commit8405f2536df82b2bfdf766119e6c99ac44c9985e (patch)
tree99f2710684958c6807ede90e8aa789feac28512b /net-dns
parentdrop old (diff)
downloadgentoo-2-8405f2536df82b2bfdf766119e6c99ac44c9985e.tar.gz
gentoo-2-8405f2536df82b2bfdf766119e6c99ac44c9985e.tar.bz2
gentoo-2-8405f2536df82b2bfdf766119e6c99ac44c9985e.zip
version bump, fixes bug #309189
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/fpdns/ChangeLog11
-rw-r--r--net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch33
-rw-r--r--net-dns/fpdns/fpdns-0.10.0_pre20130404.ebuild34
3 files changed, 76 insertions, 2 deletions
diff --git a/net-dns/fpdns/ChangeLog b/net-dns/fpdns/ChangeLog
index 2b69da5f19da..7f04bcaecd8c 100644
--- a/net-dns/fpdns/ChangeLog
+++ b/net-dns/fpdns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/fpdns
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/fpdns/ChangeLog,v 1.3 2013/03/03 17:00:56 wschlich Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/fpdns/ChangeLog,v 1.4 2014/04/26 19:26:54 wschlich Exp $
+
+*fpdns-0.10.0_pre20130404 (26 Apr 2014)
+
+ 26 Apr 2014; Wolfram Schlich <wschlich@gentoo.org>
+ +files/fpdns-0.10.0_pre20130404.ro-header.patch,
+ +fpdns-0.10.0_pre20130404.ebuild:
+ version bump, fixes bug #309189
03 Mar 2013; Wolfram Schlich <wschlich@gentoo.org> metadata.xml:
removed myself from metadata.xml, added maintainer-needed@gentoo.org
diff --git a/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch b/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch
new file mode 100644
index 000000000000..17eadbe4a139
--- /dev/null
+++ b/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch
@@ -0,0 +1,33 @@
+From ca0391377ad7150e61ff300cb5195c97a154233b Mon Sep 17 00:00:00 2001
+From: Jakob Schlyter <jakob@kirei.se>
+Date: Wed, 28 Aug 2013 10:24:11 +0200
+Subject: [PATCH] do not set header counters unless changed
+
+---
+ lib/Net/DNS/Fingerprint.pm | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/lib/Net/DNS/Fingerprint.pm b/lib/Net/DNS/Fingerprint.pm
+index d4a2e5a..e096d42 100644
+--- a/lib/Net/DNS/Fingerprint.pm
++++ b/lib/Net/DNS/Fingerprint.pm
+@@ -2171,10 +2171,12 @@ sub fp2header {
+ $header->ad(shift @list);
+ $header->cd(shift @list);
+ $header->rcode(shift @list);
+- $header->qdcount(shift @list);
+- $header->ancount(shift @list);
+- $header->nscount(shift @list);
+- $header->arcount(shift @list);
++
++ my ($qdcount, $ancount, $nscount, $arcount) = @list;
++ $header->qdcount($qdcount) unless $qdcount == $header->qdcount;
++ $header->qdcount($ancount) unless $ancount == $header->ancount;
++ $header->qdcount($nscount) unless $nscount == $header->nscount;
++ $header->qdcount($arcount) unless $arcount == $header->arcount;
+ }
+
+ sub probe {
+--
+1.9.1
+
diff --git a/net-dns/fpdns/fpdns-0.10.0_pre20130404.ebuild b/net-dns/fpdns/fpdns-0.10.0_pre20130404.ebuild
new file mode 100644
index 000000000000..1a721d50f272
--- /dev/null
+++ b/net-dns/fpdns/fpdns-0.10.0_pre20130404.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/fpdns/fpdns-0.10.0_pre20130404.ebuild,v 1.1 2014/04/26 19:26:54 wschlich Exp $
+
+EAPI=4
+
+inherit eutils perl-module
+
+DESCRIPTION="Fingerprinting DNS servers"
+HOMEPAGE="https://github.com/kirei/fpdns/"
+
+MY_P="${PN}-${PV##*_pre}"
+SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-perl/Net-DNS-0.74"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ ## fixes https://github.com/kirei/fpdns/issues/6
+ epatch "${FILESDIR}/${P}.ro-header.patch"
+}
+
+src_install() {
+ newbin apps/fpdns fpdns
+ insinto "${VENDOR_LIB}"/Net/DNS/
+ doins lib/Net/DNS/Fingerprint.pm
+}