summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-10-07 16:38:53 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-10-07 16:38:53 +0000
commit5d544b2d0e0d13b3dc7a996959fc9d61154d1d9e (patch)
tree540b16dbc0b069da6519bf8b42169e3f466307d4 /net-dns
parentQuote ${D}. (diff)
downloadgentoo-2-5d544b2d0e0d13b3dc7a996959fc9d61154d1d9e.tar.gz
gentoo-2-5d544b2d0e0d13b3dc7a996959fc9d61154d1d9e.tar.bz2
gentoo-2-5d544b2d0e0d13b3dc7a996959fc9d61154d1d9e.zip
made init-script compatible with shells other than bash (bug #194919), changed einfo to elog in pkg_postinst, some other minor cleanups.
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ez-ipupdate/ChangeLog7
-rw-r--r--net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild63
-rw-r--r--net-dns/ez-ipupdate/files/ez-ipupdate.initd8
3 files changed, 41 insertions, 37 deletions
diff --git a/net-dns/ez-ipupdate/ChangeLog b/net-dns/ez-ipupdate/ChangeLog
index 5f3f5c2d95ec..1b65dc3fefba 100644
--- a/net-dns/ez-ipupdate/ChangeLog
+++ b/net-dns/ez-ipupdate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ez-ipupdate
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.22 2007/10/06 19:30:37 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.23 2007/10/07 16:38:52 sbriesen Exp $
+
+ 07 Oct 2007; Stefan Briesenick <sbriesen@gentoo.org>
+ files/ez-ipupdate.initd, ez-ipupdate-3.0.11_beta8-r4.ebuild:
+ made init-script compatible with shells other than bash (bug #194919),
+ changed einfo to elog in pkg_postinst, some other minor cleanups.
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
ez-ipupdate-3.0.11_beta8-r4.ebuild:
diff --git a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild
index 60c9f27d00e3..e950f7df41b9 100644
--- a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild
+++ b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild,v 1.4 2007/10/06 19:30:37 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild,v 1.5 2007/10/07 16:38:52 sbriesen Exp $
inherit eutils
@@ -38,7 +38,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
newinitd "${FILESDIR}/ez-ipupdate.initd" ez-ipupdate
keepdir /etc/ez-ipupdate /var/cache/ez-ipupdate
@@ -62,40 +62,39 @@ pkg_postinst() {
chmod 750 /etc/ez-ipupdate /var/cache/ez-ipupdate
chown ez-ipupd:ez-ipupd /etc/ez-ipupdate /var/cache/ez-ipupdate
- einfo
- einfo "Please create one or more config files in"
- einfo "/etc/ez-ipupdate/. A bunch of samples can"
- einfo "be found in the doc directory."
- einfo
- einfo "All config files must have a '.conf' extension."
- einfo
- einfo "Please do not use the 'run-as-user', 'run-as-euser',"
- einfo "'cache-file' and 'pidfile' options, since these are"
- einfo "handled internally by the init-script!"
- einfo
- einfo "If you want to use ez-ipupdate in daemon mode,"
- einfo "please add 'daemon' to the config file(s) and"
- einfo "add the ez-ipupdate init-script to the default"
- einfo "runlevel."
- einfo
- einfo "Without the 'daemon' option, you can run the"
- einfo "init-script with the 'update' parameter inside"
- einfo "your PPP ip-up script."
- einfo
+ elog
+ elog "Please create one or more config files in"
+ elog "/etc/ez-ipupdate/. A bunch of samples can"
+ elog "be found in the doc directory."
+ elog
+ elog "All config files must have a '.conf' extension."
+ elog
+ elog "Please do not use the 'run-as-user', 'run-as-euser',"
+ elog "'cache-file' and 'pidfile' options, since these are"
+ elog "handled internally by the init-script!"
+ elog
+ elog "If you want to use ez-ipupdate in daemon mode,"
+ elog "please add 'daemon' to the config file(s) and"
+ elog "add the ez-ipupdate init-script to the default"
+ elog "runlevel."
+ elog
+ elog "Without the 'daemon' option, you can run the"
+ elog "init-script with the 'update' parameter inside"
+ elog "your PPP ip-up script."
+ elog
if [ -f /etc/ez-ipupdate.conf ]; then
- ewarn "!!! IMPORTANT UPDATE NOTICE !!!"
- ewarn
- ewarn "The ez-ipupdate init-script can now handle more"
- ewarn "than one config file. New config file location is"
- ewarn "/etc/ez-ipupdate/*.conf"
- ewarn
+ elog "!!! IMPORTANT UPDATE NOTICE !!!"
+ elog
+ elog "The ez-ipupdate init-script can now handle more"
+ elog "than one config file. New config file location is"
+ elog "/etc/ez-ipupdate/*.conf"
+ elog
if [ ! -f /etc/ez-ipupdate/default.conf ]; then
mv -f /etc/ez-ipupdate.conf /etc/ez-ipupdate/default.conf
- einfo "Your old configuration has been moved to"
- einfo "/etc/ez-ipupdate/default.conf"
- einfo
+ elog "Your old configuration has been moved to"
+ elog "/etc/ez-ipupdate/default.conf"
+ elog
fi
- ebeep
fi
}
diff --git a/net-dns/ez-ipupdate/files/ez-ipupdate.initd b/net-dns/ez-ipupdate/files/ez-ipupdate.initd
index 5b6698b519bf..9df54ee55ce1 100644
--- a/net-dns/ez-ipupdate/files/ez-ipupdate.initd
+++ b/net-dns/ez-ipupdate/files/ez-ipupdate.initd
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/files/ez-ipupdate.initd,v 1.2 2006/02/10 21:05:05 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/files/ez-ipupdate.initd,v 1.3 2007/10/07 16:38:53 sbriesen Exp $
-opts="${opts} update"
+opts="update"
depend() {
need net
@@ -82,11 +82,11 @@ update() {
TEXT=$(/usr/sbin/ez-ipupdate -q -R ez-ipupd -c "${CONFIG}" -b "${CACHEFILE}" 2>&1)
if eend $?; then
if [ -n "${TEXT}" ]; then
- while read line; do einfo " $line"; done < <(echo "${TEXT}")
+ echo "${TEXT}" | while read line; do einfo " $line"; done
fi
else
if [ -n "${TEXT}" ]; then
- while read line; do eerror " $line"; done < <(echo "${TEXT}")
+ echo "${TEXT}" | while read line; do eerror " $line"; done
fi
fi
done