summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-03-01 12:45:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-03-01 12:45:59 +0000
commit14dedfc9ace99a9cf7239e4840c8308f34aae73f (patch)
tree8d976c20047ab471a1a2e388faa29d53d599957b /net-dns
parentStable on amd64. Bug #168400. (diff)
downloadgentoo-2-14dedfc9ace99a9cf7239e4840c8308f34aae73f.tar.gz
gentoo-2-14dedfc9ace99a9cf7239e4840c8308f34aae73f.tar.bz2
gentoo-2-14dedfc9ace99a9cf7239e4840c8308f34aae73f.zip
Removed mysql USE flag, bug #168179.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/mydns/ChangeLog7
-rw-r--r--net-dns/mydns/mydns-1.1.0.ebuild19
2 files changed, 13 insertions, 13 deletions
diff --git a/net-dns/mydns/ChangeLog b/net-dns/mydns/ChangeLog
index 81a446823fd0..8c1d8d2ab311 100644
--- a/net-dns/mydns/ChangeLog
+++ b/net-dns/mydns/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dns/mydns
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.21 2006/11/23 17:18:54 vivo Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.22 2007/03/01 12:45:59 matsuu Exp $
+
+ 01 Mar 2007; MATSUU Takuto <matsuu@gentoo.org> mydns-1.1.0.ebuild:
+ Removed mysql USE flag, bug #168179.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org> mydns-1.1.0.ebuild:
dev-db/mysql => virtual/mysql
diff --git a/net-dns/mydns/mydns-1.1.0.ebuild b/net-dns/mydns/mydns-1.1.0.ebuild
index e740ba37a045..7b480755cb8e 100644
--- a/net-dns/mydns/mydns-1.1.0.ebuild
+++ b/net-dns/mydns/mydns-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-1.1.0.ebuild,v 1.7 2006/11/23 17:18:54 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-1.1.0.ebuild,v 1.8 2007/03/01 12:45:59 matsuu Exp $
inherit eutils
@@ -11,16 +11,13 @@ SRC_URI="http://mydns.bboy.net/download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ~amd64 ~hppa ia64 ~ppc sparc x86"
-IUSE="debug mysql nls postgres ssl static zlib"
+IUSE="debug nls postgres ssl static zlib"
RDEPEND="virtual/libc
ssl? ( dev-libs/openssl )
zlib? ( sys-libs/zlib )
- || (
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- !postgres? ( virtual/mysql )
- )"
+ postgres? ( dev-db/postgresql )
+ !postgres? ( virtual/mysql )"
DEPEND="${RDEPEND}
sys-devel/bison"
@@ -36,7 +33,7 @@ src_unpack() {
src_compile() {
local myconf
- if use mysql || ! use postgres; then
+ if ! use postgres; then
myconf="${myconf} --with-mysql"
else
myconf="${myconf} --without-mysql --with-pgsql"
@@ -60,7 +57,7 @@ src_install() {
exeinto /etc/init.d; newexe ${FILESDIR}/mydns.rc6 mydns || die
- if use mysql || ! use postgres; then
+ if ! use postgres; then
sed -i -e 's/__db__/mysql/g' ${D}/etc/init.d/mydns || die
dodoc QUICKSTART.mysql README.mysql
else
@@ -75,7 +72,7 @@ pkg_postinst() {
einfo
einfo "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
einfo "# chmod 0600 /etc/mydns.conf"
- if use mysql || ! use postgres; then
+ if ! use postgres; then
einfo "# mysqladmin -u <useruname> -p create mydns"
einfo "# /usr/sbin/mydns --create-tables | mysql -u <username> -p mydns"
einfo