summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-06-20 09:53:37 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-06-20 09:53:37 +0000
commite8f1e94995055a06b50934ddf55eef7ffeaaa19d (patch)
tree5946d6b485cd59adc78c1c72dec91d7111db3e73 /net-dialup
parentfirst use of a ~ dep (diff)
downloadgentoo-2-e8f1e94995055a06b50934ddf55eef7ffeaaa19d.tar.gz
gentoo-2-e8f1e94995055a06b50934ddf55eef7ffeaaa19d.tar.bz2
gentoo-2-e8f1e94995055a06b50934ddf55eef7ffeaaa19d.zip
crux informed me that ppp had permanently moved to a new location, changed in -r1
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r11
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r1 b/net-dialup/ppp/files/digest-ppp-2.4.1-r1
new file mode 100644
index 000000000000..d9bd23c07d7f
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r1
@@ -0,0 +1 @@
+MD5 fbc256801d5fcd8015039b149ae95eb0 ppp-2.4.1.tar.gz
diff --git a/net-dialup/ppp/ppp-2.4.1-r1.ebuild b/net-dialup/ppp/ppp-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..4ec650220170
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r1.ebuild,v 1.1 2001/06/20 09:53:37 hallski Exp $
+
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Point-to-point protocol - used for communicating with your ISP"
+SRC_URI="ftp://cs.anu.edu.au/pub/software/ppp/${A}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ try ./configure --prefix=/usr
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" -e "s/LIBS =/LIBS = -lcrypt/" Makefile.orig > Makefile
+ cd ../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O:COPTS = ${CFLAGS}:" Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+ export CC=gcc
+ try make
+}
+
+src_install() {
+ into /usr
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+ dodir /etc/ppp
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ insinto /etc/modules
+ doins ${FILESDIR}/modules.ppp
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+}