summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-02-12 10:57:32 +0000
committerAlin Năstac <mrness@gentoo.org>2006-02-12 10:57:32 +0000
commite889d3e0e20045b4c796ad35c9e0f46c70919803 (patch)
treec44fe544e041bb0085979a5a26246c112c850650 /net-dialup
parentversion bump + remove old versions (diff)
downloadgentoo-2-e889d3e0e20045b4c796ad35c9e0f46c70919803.tar.gz
gentoo-2-e889d3e0e20045b4c796ad35c9e0f46c70919803.tar.bz2
gentoo-2-e889d3e0e20045b4c796ad35c9e0f46c70919803.zip
Fix "unresolved symbol set_cpus_allowed" on SMP kernels (#122103).
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/bewan-adsl/ChangeLog9
-rw-r--r--net-dialup/bewan-adsl/Manifest13
-rw-r--r--net-dialup/bewan-adsl/bewan-adsl-0.9.3-r1.ebuild92
-rw-r--r--net-dialup/bewan-adsl/files/bewan-adsl-0.9.3-smp.patch12
-rw-r--r--net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3-r11
5 files changed, 116 insertions, 11 deletions
diff --git a/net-dialup/bewan-adsl/ChangeLog b/net-dialup/bewan-adsl/ChangeLog
index 073df6f589cd..155e64c1b8ca 100644
--- a/net-dialup/bewan-adsl/ChangeLog
+++ b/net-dialup/bewan-adsl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/bewan-adsl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.6 2006/02/08 19:00:09 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.7 2006/02/12 10:57:32 mrness Exp $
+
+*bewan-adsl-0.9.3-r1 (12 Feb 2006)
+
+ 12 Feb 2006; Alin Nastac <mrness@gentoo.org>
+ +files/bewan-adsl-0.9.3-smp.patch, +bewan-adsl-0.9.3-r1.ebuild:
+ Fix "unresolved symbol set_cpus_allowed" on SMP kernels (#122103),
+ thanks to Joe Stroller <stroller@bigfoot.com>.
*bewan-adsl-0.9.3 (08 Feb 2006)
diff --git a/net-dialup/bewan-adsl/Manifest b/net-dialup/bewan-adsl/Manifest
index 01eb716f6f6b..04ee840c7af7 100644
--- a/net-dialup/bewan-adsl/Manifest
+++ b/net-dialup/bewan-adsl/Manifest
@@ -1,19 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 36ef61b211d19830816f09a020f5390f ChangeLog 1255
MD5 d0efc1235be91ab4c58bddd5f1b38b59 bewan-adsl-0.8.7.ebuild 2353
MD5 bd16ca2d11981fbdae9a990f3af11ff5 bewan-adsl-0.9.0.ebuild 2127
+MD5 4197f3daf058926340d424f5ba565b08 bewan-adsl-0.9.3-r1.ebuild 2454
MD5 492ec7a7a8a9b9f2a31ed9cb55491bf8 bewan-adsl-0.9.3.ebuild 2294
+MD5 9634edac04690ec8717dc703c52dde0a files/bewan-adsl-0.9.3-smp.patch 415
MD5 0572b020603885cca9caf29f664e2f44 files/bewan-adsl-kill-timeout.patch 1093
MD5 96c16fb5ea4312bc3e4b2300e0a7ce69 files/digest-bewan-adsl-0.8.7 59
MD5 d93f0e970aec5e90512811f43cd55c48 files/digest-bewan-adsl-0.9.0 59
MD5 0582f71161d9846420b9ee9bd856e9b2 files/digest-bewan-adsl-0.9.3 82
+MD5 0582f71161d9846420b9ee9bd856e9b2 files/digest-bewan-adsl-0.9.3-r1 82
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFD6j/LjG8pv1lIUX4RAvvlAJ9yb0g870ioDMOBBHssPW6fh4uP/gCg1XaF
-1SZOKqWCY4tqyX346+FaHbQ=
-=OlQ+
------END PGP SIGNATURE-----
diff --git a/net-dialup/bewan-adsl/bewan-adsl-0.9.3-r1.ebuild b/net-dialup/bewan-adsl/bewan-adsl-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..9f6b1aa9722d
--- /dev/null
+++ b/net-dialup/bewan-adsl/bewan-adsl-0.9.3-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/bewan-adsl-0.9.3-r1.ebuild,v 1.1 2006/02/12 10:57:32 mrness Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Bewan ADSL PCI&USB st driver"
+SRC_URI="http://www.bewan.com/bewan/drivers/A1012-A1006-A904-A888-A983-${PV}.tgz"
+HOMEPAGE="http://www.bewan.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="usb doc"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+
+S="${WORKDIR}/unicorn"
+
+PCI_S="${S}/unicorn_pci"
+USB_S="${S}/unicorn_usb"
+BUILD_PARAMS="KERNEL_SOURCES=${KV_DIR} KVERS=${KV_FULL}"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="ATM"
+ATM_ERROR="This driver requires you to build your kernel with support for Asynchronous Transfer Mode (ATM)"
+
+pkg_setup() {
+ MODULE_NAMES="unicorn_pci_atm(extra:${PCI_S}) unicorn_pci_eth(extra:${PCI_S})"
+ use usb && MODULE_NAMES="${MODULE_NAMES} unicorn_usb_atm(extra:${USB_S}) unicorn_usb_eth(extra:${USB_S})"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix "unresolved symbol set_cpus_allowed" on SMP kernels (#122103)
+ # Upstream consider actual version to be thread safe
+ epatch "${FILESDIR}/${P}-smp.patch"
+
+ # Fix up broken Makefiles
+ convert_to_m "${PCI_S}/Makefile"
+ use usb && convert_to_m "${USB_S}/Makefile"
+}
+
+src_compile() {
+ einfo "Build common library"
+ cd "${S}/libm"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+
+ einfo "Building tools"
+ cd "${S}/tools"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+ cd "${S}/unicorntest"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ cd "${S}"
+ #Install tools
+ dodir /usr/bin
+ cd "${S}/tools" && einstall DESTDIR="${D}" prefix=/usr || \
+ die "Cannot install tools"
+ cd "${S}/unicorntest" && einstall DESTDIR="${D}" prefix=/usr || \
+ die "Cannot install unicorntest"
+ doman "${S}/Documentation/unicorntest.8"
+
+ if use doc; then
+ #Install documantation
+ cd "${S}"
+ dodoc README
+ docinto RFCs
+ dodoc RFCs/*
+ docinto scripts
+ dodoc scripts/*
+ fi
+}
+
+pkg_postinst() {
+ einfo "To load the driver do 'modprobe unicorn_atm' and 'modprobe unicorn_pci' "
+ einfo "and then do what you want with it (configure your pppd)"
+ einfo "OR"
+ einfo "it's time to look at the README file, the scripts directory gives you"
+ einfo "two comprehensive ways to load the driver, configure pppd and launch it."
+
+ linux-mod_pkg_postinst
+}
diff --git a/net-dialup/bewan-adsl/files/bewan-adsl-0.9.3-smp.patch b/net-dialup/bewan-adsl/files/bewan-adsl-0.9.3-smp.patch
new file mode 100644
index 000000000000..7bcc80dd2c62
--- /dev/null
+++ b/net-dialup/bewan-adsl/files/bewan-adsl-0.9.3-smp.patch
@@ -0,0 +1,12 @@
+diff -Nur unicorn.orig/msw/linrapi.c unicorn/msw/linrapi.c
+--- unicorn.orig/msw/linrapi.c 2006-01-02 18:54:30.000000000 +0200
++++ unicorn/msw/linrapi.c 2006-02-12 12:38:32.453937500 +0200
+@@ -922,7 +922,7 @@
+ #endif
+ // Hack to try to make it work on SMP !!!!
+ // Lock the threads to CPU #0
+- set_cpus_allowed(k->thread,CPU_MASK_CPU0);
++ //set_cpus_allowed(k->thread,CPU_MASK_CPU0);
+ #endif
+ return SUCCESS;
+ }
diff --git a/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3-r1 b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3-r1
new file mode 100644
index 000000000000..9dd6e6317c42
--- /dev/null
+++ b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3-r1
@@ -0,0 +1 @@
+MD5 ff9829f03168279a079d05aea780ee99 A1012-A1006-A904-A888-A983-0.9.3.tgz 1176291