summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-20 09:00:50 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-20 09:00:50 +0000
commitb6b2b81b0728f6a5df8fe4eaa10e91770f747623 (patch)
tree60f2717d9732b263afcbc930357b65cb1ece3d66 /net-dialup
parentRemove weird has_version check in pkg_postrm I inherited from old ebuild, it ... (diff)
downloadgentoo-2-b6b2b81b0728f6a5df8fe4eaa10e91770f747623.tar.gz
gentoo-2-b6b2b81b0728f6a5df8fe4eaa10e91770f747623.tar.bz2
gentoo-2-b6b2b81b0728f6a5df8fe4eaa10e91770f747623.zip
Version bump (#270657).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/pptpclient/ChangeLog10
-rw-r--r--net-dialup/pptpclient/files/pptpclient-1.7.2-process-name.patch42
-rw-r--r--net-dialup/pptpclient/pptpclient-1.7.2.ebuild52
3 files changed, 102 insertions, 2 deletions
diff --git a/net-dialup/pptpclient/ChangeLog b/net-dialup/pptpclient/ChangeLog
index 8aa57e1e67ce..aff3dc58e01a 100644
--- a/net-dialup/pptpclient/ChangeLog
+++ b/net-dialup/pptpclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/pptpclient
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.48 2007/04/15 09:57:54 mrness Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.49 2009/06/20 09:00:49 mrness Exp $
+
+*pptpclient-1.7.2 (20 Jun 2009)
+
+ 20 Jun 2009; Alin Năstac <mrness@gentoo.org>
+ +files/pptpclient-1.7.2-process-name.patch, +pptpclient-1.7.2.ebuild:
+ Version bump (#270657).
15 Apr 2007; Alin Năstac <mrness@gentoo.org> -pptpclient-1.7.1.ebuild:
Remove old revision.
diff --git a/net-dialup/pptpclient/files/pptpclient-1.7.2-process-name.patch b/net-dialup/pptpclient/files/pptpclient-1.7.2-process-name.patch
new file mode 100644
index 000000000000..b0051f81bde0
--- /dev/null
+++ b/net-dialup/pptpclient/files/pptpclient-1.7.2-process-name.patch
@@ -0,0 +1,42 @@
+diff -Nru pptp-1.7.2.orig/pptp.c pptp-1.7.2/pptp.c
+--- pptp-1.7.2.orig/pptp.c 2008-05-14 08:33:55.000000000 +0200
++++ pptp-1.7.2/pptp.c 2009-06-20 10:53:07.000000000 +0200
+@@ -59,11 +59,7 @@
+ #include "pptp_callmgr.h"
+ #include "pptp_gre.h"
+ #include "version.h"
+-#if defined(__linux__)
+-#include <sys/prctl.h>
+-#else
+ #include "inststr.h"
+-#endif
+ #include "util.h"
+ #include "pptp_quirks.h"
+ #include "pqueue.h"
+@@ -394,12 +390,7 @@
+ char *tty_name = ttyname(tty_fd);
+ snprintf(buf, sizeof(buf), "pptp: GRE-to-PPP gateway on %s",
+ tty_name ? tty_name : "(null)");
+-#ifdef PR_SET_NAME
+- rc = prctl(PR_SET_NAME, "pptpgw", 0, 0, 0);
+- if (rc != 0) perror("prctl");
+-#else
+ inststr(argc, argv, envp, buf);
+-#endif
+ if (sigsetjmp(env, 1)!= 0) goto shutdown;
+
+ signal(SIGINT, sighandler);
+@@ -495,13 +486,7 @@
+ char *my_argv[3] = { argv[0], inet_ntoa(inetaddr), phonenr };
+ char buf[128];
+ snprintf(buf, sizeof(buf), "pptp: call manager for %s", my_argv[1]);
+-#ifdef PR_SET_NAME
+- int rc;
+- rc = prctl(PR_SET_NAME, "pptpcm", 0, 0, 0);
+- if (rc != 0) perror("prctl");
+-#else
+ inststr(argc, argv, envp, buf);
+-#endif
+ exit(callmgr_main(3, my_argv, envp));
+ }
+
diff --git a/net-dialup/pptpclient/pptpclient-1.7.2.ebuild b/net-dialup/pptpclient/pptpclient-1.7.2.ebuild
new file mode 100644
index 000000000000..a53ad4d3fcd6
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.7.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.2.ebuild,v 1.1 2009/06/20 09:00:49 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${P/client}
+MY_CMD=pptp-command-20050401
+
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
+ mirror://gentoo/${MY_CMD}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tk"
+
+DEPEND=">=net-dialup/ppp-2.4.2
+ dev-lang/perl
+ tk? ( dev-perl/perl-tk )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" #make test is useless and vector_test.c is broken
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-process-name.patch
+}
+
+src_compile() {
+ emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dosbin pptp
+ dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING
+ dodoc Documentation/*
+ dodir /etc/pptp.d
+
+ # The current version of pptp-linux doesn't include the
+ # RH-specific portions, so include them ourselves.
+ insinto /etc/ppp
+ doins options.pptp
+ newsbin "${WORKDIR}/${MY_CMD}" pptp-command
+ dosbin "${FILESDIR}/pptp_fe.pl"
+ use tk && dosbin "${FILESDIR}/xpptp_fe.pl"
+}