summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-07-14 06:09:12 +0000
committerAlin Năstac <mrness@gentoo.org>2007-07-14 06:09:12 +0000
commit69e71da01456df7f59b078d1217b0f90113bee13 (patch)
treecbea5ebb7a25758943d09db38b2649c96aa0aab9 /net-dialup
parentBump. Changes include: Additional valuator per axis reporting unmodified phys... (diff)
downloadgentoo-2-69e71da01456df7f59b078d1217b0f90113bee13.tar.gz
gentoo-2-69e71da01456df7f59b078d1217b0f90113bee13.tar.bz2
gentoo-2-69e71da01456df7f59b078d1217b0f90113bee13.zip
Fix modem connection detecting problem related to wvstreams-4.3, thanks to Grigorij Mozhaev <zcrendel at gmail dot com> (#180314).
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/gnome-ppp/ChangeLog9
-rw-r--r--net-dialup/gnome-ppp/files/digest-gnome-ppp-0.3.23-r13
-rw-r--r--net-dialup/gnome-ppp/files/gnome-ppp-0.3.23-wvdial-notify.patch85
-rw-r--r--net-dialup/gnome-ppp/gnome-ppp-0.3.23-r1.ebuild38
4 files changed, 134 insertions, 1 deletions
diff --git a/net-dialup/gnome-ppp/ChangeLog b/net-dialup/gnome-ppp/ChangeLog
index 05b30bb1d74c..ea10f00036f4 100644
--- a/net-dialup/gnome-ppp/ChangeLog
+++ b/net-dialup/gnome-ppp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/gnome-ppp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnome-ppp/ChangeLog,v 1.21 2007/04/14 10:33:44 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnome-ppp/ChangeLog,v 1.22 2007/07/14 06:09:11 mrness Exp $
+
+*gnome-ppp-0.3.23-r1 (14 Jul 2007)
+
+ 14 Jul 2007; Alin Năstac <mrness@gentoo.org>
+ +files/gnome-ppp-0.3.23-wvdial-notify.patch, +gnome-ppp-0.3.23-r1.ebuild:
+ Fix modem connection detecting problem related to wvstreams-4.3, thanks to
+ Grigorij Mozhaev <zcrendel at gmail dot com> (#180314).
14 Apr 2007; Alin Năstac <mrness@gentoo.org>
+files/gnome-ppp-0.3.23-implicit-decl.patch, gnome-ppp-0.3.23.ebuild:
diff --git a/net-dialup/gnome-ppp/files/digest-gnome-ppp-0.3.23-r1 b/net-dialup/gnome-ppp/files/digest-gnome-ppp-0.3.23-r1
new file mode 100644
index 000000000000..aab945707dd2
--- /dev/null
+++ b/net-dialup/gnome-ppp/files/digest-gnome-ppp-0.3.23-r1
@@ -0,0 +1,3 @@
+MD5 ec2e20fc713a01c953d759bea3df8618 gnome-ppp-0.3.23.tar.bz2 330907
+RMD160 18f946bf475506f7a5f948b83f64439ca70646c1 gnome-ppp-0.3.23.tar.bz2 330907
+SHA256 ec606b5648182375e0d02a5cf365c5bf9aba312fb0fd105c24db683f42646e14 gnome-ppp-0.3.23.tar.bz2 330907
diff --git a/net-dialup/gnome-ppp/files/gnome-ppp-0.3.23-wvdial-notify.patch b/net-dialup/gnome-ppp/files/gnome-ppp-0.3.23-wvdial-notify.patch
new file mode 100644
index 000000000000..b3ec322d5024
--- /dev/null
+++ b/net-dialup/gnome-ppp/files/gnome-ppp-0.3.23-wvdial-notify.patch
@@ -0,0 +1,85 @@
+diff -Nru gnome-ppp-0.3.23.orig/src/gnome-ppp-connected.c gnome-ppp-0.3.23/src/gnome-ppp-connected.c
+--- gnome-ppp-0.3.23.orig/src/gnome-ppp-connected.c 2005-02-07 23:23:10.000000000 +0200
++++ gnome-ppp-0.3.23/src/gnome-ppp-connected.c 2007-07-14 09:00:51.000000000 +0300
+@@ -51,6 +51,8 @@
+
+ gboolean on_conn_delete_event (GtkWidget *widget, GdkEvent *event, gpointer data)
+ {
++ gnome_ppp.connected.show = FALSE;
++ gtk_widget_hide (gnome_ppp.connected.window);
+ return TRUE;
+ }
+
+diff -Nru gnome-ppp-0.3.23.orig/src/gnome-ppp-wvdial.c gnome-ppp-0.3.23/src/gnome-ppp-wvdial.c
+--- gnome-ppp-0.3.23.orig/src/gnome-ppp-wvdial.c 2005-02-01 21:28:25.000000000 +0200
++++ gnome-ppp-0.3.23/src/gnome-ppp-wvdial.c 2007-07-14 09:01:29.000000000 +0300
+@@ -56,13 +56,13 @@
+
+ g_print ("GNOME PPP: STDERR: %s", line);
+
+- if (g_strrstr (line, "--> Cannot open") != NULL)
++ if (g_strrstr (line, "Cannot open") != NULL)
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Can not open modem."));
+
+- if (g_strrstr (line, "--> Modem not responding") != NULL)
++ if (g_strrstr (line, "Modem not responding") != NULL)
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Modem not responding."));
+
+- if (g_strrstr (line, "--> Please enter password") != NULL) {
++ if (g_strrstr (line, "Please enter password") != NULL) {
+ const gchar *password;
+
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Sending password..."));
+@@ -75,7 +75,7 @@
+ g_io_channel_shutdown (in, TRUE, NULL);
+ }
+
+- if (g_strrstr (line, "--> Configuration does not specify a valid password.") != NULL)
++ if (g_strrstr (line, "Configuration does not specify a valid password.") != NULL)
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("No valid password."));
+
+ if (g_strrstr (line, "ATM") != NULL) {
+@@ -90,13 +90,13 @@
+ g_free (message);
+ }
+
+- if (g_strrstr (line, "--> Carrier detected. Waiting for prompt.") != NULL)
++ if (g_strrstr (line, "Carrier detected. Waiting for prompt.") != NULL)
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Waiting for prompt..."));
+
+ if (g_strrstr (line, "Username:") != NULL)
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Authenticating..."));
+
+- if (g_strrstr (line, "--> Using interface") != NULL) {
++ if (g_strrstr (line, "Using interface") != NULL) {
+ gchar iface[255];
+ gchar tmp[255];
+
+@@ -104,14 +104,14 @@
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.details.interface), &iface[0]);
+ }
+ /* in case we are using auto reconnect */
+- if (g_strrstr (line, "--> Auto Reconnect") != NULL) {
++ if (g_strrstr (line, "Auto Reconnect") != NULL) {
+ gtk_label_set_text (GTK_LABEL (gnome_ppp.connecting.msgs), _("Reconnecting..."));
+ gtk_widget_hide (gnome_ppp.gnome_ppp.window);
+ gtk_widget_hide (gnome_ppp.details.window);
+ gtk_widget_show (gnome_ppp.connecting.window);
+ }
+ /* we're about to connect (pppd) */
+- if (g_strrstr (line, "--> Starting pppd") != NULL) {
++ if (g_strrstr (line, "Starting pppd") != NULL) {
+ gboolean minimize;
+
+ minimize = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (gnome_ppp.setup.minimize));
+@@ -135,8 +135,8 @@
+ gnome_ppp.connected.update = g_timeout_add (1000, (GSourceFunc)timer, NULL);
+ }
+
+- if (g_strrstr (line, "--> The PPP daemon has died") != NULL
+- || g_strrstr (line, "--> Disconnecting") != NULL) {
++ if (g_strrstr (line, "The PPP daemon has died.") != NULL
++ || g_strrstr (line, "Disconnecting") != NULL) {
+
+ if (gnome_ppp.connected.update) {
+ g_source_remove (gnome_ppp.connected.update);
diff --git a/net-dialup/gnome-ppp/gnome-ppp-0.3.23-r1.ebuild b/net-dialup/gnome-ppp/gnome-ppp-0.3.23-r1.ebuild
new file mode 100644
index 000000000000..06424e3f76d9
--- /dev/null
+++ b/net-dialup/gnome-ppp/gnome-ppp-0.3.23-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnome-ppp/gnome-ppp-0.3.23-r1.ebuild,v 1.1 2007/07/14 06:09:11 mrness Exp $
+
+inherit gnome2 eutils
+
+MAJOR_V=${PV%.[0-9]*}
+
+DESCRIPTION="A GNOME 2 WvDial frontend"
+HOMEPAGE="None available"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-dialup/wvdial-1.54
+ >=gnome-base/libglade-2.4
+ >=x11-libs/gtk+-2.4"
+DEPEND="sys-devel/gettext
+ dev-util/pkgconfig
+ dev-util/intltool
+ ${RDEPEND}"
+
+USE_DESTDIR="1"
+DOCS="ChangeLog"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-implicit-decl.patch
+ epatch "${FILESDIR}"/${P}-wvdial-notify.patch
+}
+
+src_install() {
+ gnome2_src_install top_builddir="${S}"
+}