summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-03-05 16:06:46 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-03-05 16:06:46 +0000
commit67ff54f2d280fdeb2eb0d82507b06d5a22dff696 (patch)
tree841bf621296d66df60f999a28ead382ddc9d0bb4 /net-dialup
parentmaking it work for icc as well as gcc (diff)
downloadgentoo-2-67ff54f2d280fdeb2eb0d82507b06d5a22dff696.tar.gz
gentoo-2-67ff54f2d280fdeb2eb0d82507b06d5a22dff696.tar.bz2
gentoo-2-67ff54f2d280fdeb2eb0d82507b06d5a22dff696.zip
Made output nicer in the config script
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild b/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
index f010799b171b..2a8b9fe951d4 100644
--- a/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
+++ b/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild,v 1.2 2005/03/04 13:09:49 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild,v 1.3 2005/03/05 16:06:46 genstef Exp $
inherit linux-mod eutils
@@ -222,11 +222,11 @@ pkg_config() {
readvalue FCDSL_PROVIDER "Enter the name of your ISP"
if [ ! -e "/etc/ppp/peers/${FCDSL_PROVIDER}" ]; then
readvalue FCDSL_USER "Enter your user name"
- if [ "$(grep "${FCDSL_USER}" /etc/ppp/pap-secrets)" == "" ]; then
+ if ! grep "${FCDSL_USER}" /etc/ppp/pap-secrets >/dev/null 2>&1; then
readpassword FCDSL_PASSWORD
echo '"'${FCDSL_USER}'" * "'${FCDSL_PASSWORD}'"' >>/etc/ppp/pap-secrets
unset FCDSL_PASSWORD
- cat <<EOF >>/etc/ppp/peers/${FCDSL_PROVIDER}
+ cat <<EOF >/etc/ppp/peers/${FCDSL_PROVIDER}
connect ""
ipcp-accept-remote
ipcp-accept-local
@@ -260,18 +260,20 @@ EOF
einfo "or"
einfo " pppd call \"${FCDSL_PROVIDER}\""
else
- ewarn "User \"${FCDSL_USER}\" always exists in \"/etc/ppp/pap-secrets\"!"
+ ewarn "User \"${FCDSL_USER}\" already exists in \"/etc/ppp/pap-secrets\"!"
fi
else
- ewarn "Peer file \"/etc/ppp/peers/${FCDSL_PROVIDER}\" always exists!"
+ ewarn "Peer file \"/etc/ppp/peers/${FCDSL_PROVIDER}\" already exists!"
fi
#Uncomment correspondent lines in /etc/capi.conf & /etc/modules.d/fcdsl
if [ -f /etc/capi.conf ]; then
- sed -i -e "s:^#${FCDSL_MODULE}:${FCDSL_MODULE}" /etc/capi.conf
+ sed -i -e "s:^#${FCDSL_MODULE}:${FCDSL_MODULE}:" \
+ /etc/capi.conf >/dev/null 2>&1
fi
if [ -f /etc/modules.d/fcdsl ]; then
- sed -i -e "s:^#options +${FCDSL_MODULE}:options ${FCDSL_MODULE}" /etc/modules.d/fcdsl
+ sed -i -e "s:^#options ${FCDSL_MODULE}:options ${FCDSL_MODULE}:" \
+ /etc/modules.d/fcdsl >/dev/null 2>&1
fi
else
ewarn "No AVM FRITZ!Card DSL found!"