summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-11 15:03:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-11 15:03:58 +0000
commit373bd78519c7f7813dd3113ba716b1ec553a34ec (patch)
tree6a02ab7741a7f6204fb8ee7bf0591f3e784ccf43 /net-dialup
parentDrop hppa keywords and old versions per bug 324511 (diff)
downloadgentoo-2-373bd78519c7f7813dd3113ba716b1ec553a34ec.tar.gz
gentoo-2-373bd78519c7f7813dd3113ba716b1ec553a34ec.tar.bz2
gentoo-2-373bd78519c7f7813dd3113ba716b1ec553a34ec.zip
Version bump (new project site), take over maintainership since this package was rusting since Mike stopped maintaining it.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/picocom/ChangeLog11
-rw-r--r--net-dialup/picocom/metadata.xml5
-rw-r--r--net-dialup/picocom/picocom-1.6.ebuild37
3 files changed, 50 insertions, 3 deletions
diff --git a/net-dialup/picocom/ChangeLog b/net-dialup/picocom/ChangeLog
index 2e661ccffe43..2be2cf5624b4 100644
--- a/net-dialup/picocom/ChangeLog
+++ b/net-dialup/picocom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/picocom
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/picocom/ChangeLog,v 1.4 2007/06/07 14:30:40 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/picocom/ChangeLog,v 1.5 2010/07/11 15:03:58 flameeyes Exp $
+
+*picocom-1.6 (11 Jul 2010)
+
+ 11 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> +picocom-1.6.ebuild,
+ metadata.xml:
+ Version bump (new project site), take over maintainership since this
+ package was rusting since Mike stopped maintaining it.
07 Jun 2007; Diego Pettenò <flameeyes@gentoo.org> picocom-1.4.ebuild:
Add ~x86-fbsd keyword.
diff --git a/net-dialup/picocom/metadata.xml b/net-dialup/picocom/metadata.xml
index 8290ba4db1ac..1519d9cb2747 100644
--- a/net-dialup/picocom/metadata.xml
+++ b/net-dialup/picocom/metadata.xml
@@ -1,5 +1,8 @@
<?xml version = '1.0' encoding = 'UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-dialup</herd>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/net-dialup/picocom/picocom-1.6.ebuild b/net-dialup/picocom/picocom-1.6.ebuild
new file mode 100644
index 000000000000..d3180bcd4d41
--- /dev/null
+++ b/net-dialup/picocom/picocom-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/picocom/picocom-1.6.ebuild,v 1.1 2010/07/11 15:03:58 flameeyes Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="http://code.google.com/p/picocom/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:\./picocom:picocom:' pcasc
+}
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm} || die
+ doman picocom.8 || die
+ dohtml picocom.8.html || die
+ dodoc CHANGES CHANGES.old CONTRIBUTORS NEWS README TODO || die
+}