summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-20 04:49:45 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-20 04:49:45 +0000
commit2637da3ea12eccf479540430fac848fddaef678d (patch)
tree2876654404e372d0d83a1c9356b007c87d12c159 /net-dialup/xl2tpd
parentEnable compat by default since perl/python need it #383745 by Alexandre Rosto... (diff)
downloadgentoo-2-2637da3ea12eccf479540430fac848fddaef678d.tar.gz
gentoo-2-2637da3ea12eccf479540430fac848fddaef678d.tar.bz2
gentoo-2-2637da3ea12eccf479540430fac848fddaef678d.zip
Version bump, bug #376919 wrt andreyc.
(Portage version: 2.1.10.16/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/ChangeLog8
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-1.3.0-LDFLAGS.patch13
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-dnsretry.patch8
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.0.ebuild44
4 files changed, 69 insertions, 4 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index fbb952d6ecd5..33486e6da740 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.23 2011/07/18 07:33:10 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.24 2011/09/20 04:49:45 pva Exp $
+
+*xl2tpd-1.3.0 (20 Sep 2011)
+
+ 20 Sep 2011; Peter Volkov <pva@gentoo.org> +xl2tpd-1.3.0.ebuild,
+ files/xl2tpd-dnsretry.patch, +files/xl2tpd-1.3.0-LDFLAGS.patch:
+ Version bump, bug #376919 wrt andreyc.
*xl2tpd-1.2.8 (18 Jul 2011)
diff --git a/net-dialup/xl2tpd/files/xl2tpd-1.3.0-LDFLAGS.patch b/net-dialup/xl2tpd/files/xl2tpd-1.3.0-LDFLAGS.patch
new file mode 100644
index 000000000000..a87ab3fff8b9
--- /dev/null
+++ b/net-dialup/xl2tpd/files/xl2tpd-1.3.0-LDFLAGS.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile'
+--- Makefile 2011-09-20 04:44:23 +0000
++++ Makefile 2011-09-20 04:44:35 +0000
+@@ -114,7 +114,7 @@
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LDLIBS)
+
+ $(CONTROL_EXEC): $(CONTROL_SRCS)
+- $(CC) $(CONTROL_SRCS) -o $@
++ $(CC) $(LDFLAGS) $(CONTROL_SRCS) -o $@
+
+ pfc:
+ $(CC) $(CFLAGS) -c contrib/pfc.c
+
diff --git a/net-dialup/xl2tpd/files/xl2tpd-dnsretry.patch b/net-dialup/xl2tpd/files/xl2tpd-dnsretry.patch
index cf45194b8254..b27703fe435e 100644
--- a/net-dialup/xl2tpd/files/xl2tpd-dnsretry.patch
+++ b/net-dialup/xl2tpd/files/xl2tpd-dnsretry.patch
@@ -1,6 +1,8 @@
-diff -Nru xl2tpd-1.2.6.orig/xl2tpd.c xl2tpd-1.2.6/xl2tpd.c
---- xl2tpd-1.2.6.orig/xl2tpd.c 2010-05-10 22:35:43.000000000 +0200
-+++ xl2tpd-1.2.6/xl2tpd.c 2010-08-15 22:02:14.000000000 +0200
+https://bugs.gentoo.org/show_bug.cgi?id=307489
+http://homenet.beeline.ru/index.php?showtopic=192551&st=0&p=1063626345&#entry1063626345
+
+--- xl2tpd.c 2010-05-10 22:35:43.000000000 +0200
++++ xl2tpd.c 2010-08-15 22:02:14.000000000 +0200
@@ -587,9 +587,33 @@
hp = gethostbyname (host);
if (!hp)
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.0.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.0.ebuild
new file mode 100644
index 000000000000..09fcc40db73d
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.0.ebuild,v 1.1 2011/09/20 04:49:45 pva Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dnsretry"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.0-LDFLAGS.patch"
+ sed -i Makefile -e 's| -O2 ||g' || die "sed Makefile"
+ use dnsretry && epatch "${FILESDIR}/${PN}-dnsretry.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${ED}/etc/xl2tpd/l2tp-secrets" || die
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init xl2tpd
+
+ keepdir /var/run/xl2tpd
+}