summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-05-26 01:22:21 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-05-26 01:22:21 +0000
commit9aa9921f5aa93ff2dbbf5f4f25efa1defd3eb7a3 (patch)
treeb5d4c37bedd7f7457864f6f54e41032838631122 /net-dialup/speedtouch
parentNew version (diff)
downloadgentoo-2-9aa9921f5aa93ff2dbbf5f4f25efa1defd3eb7a3.tar.gz
gentoo-2-9aa9921f5aa93ff2dbbf5f4f25efa1defd3eb7a3.tar.bz2
gentoo-2-9aa9921f5aa93ff2dbbf5f4f25efa1defd3eb7a3.zip
New version
Diffstat (limited to 'net-dialup/speedtouch')
-rw-r--r--net-dialup/speedtouch/ChangeLog8
-rw-r--r--net-dialup/speedtouch/Manifest4
-rw-r--r--net-dialup/speedtouch/files/digest-speedtouch-1.2_beta11
-rw-r--r--net-dialup/speedtouch/speedtouch-1.2_beta1.ebuild66
4 files changed, 76 insertions, 3 deletions
diff --git a/net-dialup/speedtouch/ChangeLog b/net-dialup/speedtouch/ChangeLog
index 97e167e6705f..1752a64d800b 100644
--- a/net-dialup/speedtouch/ChangeLog
+++ b/net-dialup/speedtouch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/speedtouch
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.5 2003/05/23 07:47:11 killian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.6 2003/05/26 01:21:35 lu_zero Exp $
+
+*speedtouch-1.2_beta1 (25 May 2003)
+
+ 25 May 2003; Luca Barbato <lu_zero@gentoo.org> speedtouch-1.2_beta1.ebuild :
+ New Version, should support more models. Filtered some flags that break on
+ ppc. Thanks to Alessandro Sappia <a.sappia@ngi.it>
*speedtouch-1.1 (30 Aug 2002)
diff --git a/net-dialup/speedtouch/Manifest b/net-dialup/speedtouch/Manifest
index 02c8ead2d71f..23a352bb7966 100644
--- a/net-dialup/speedtouch/Manifest
+++ b/net-dialup/speedtouch/Manifest
@@ -1,6 +1,6 @@
-MD5 6f2837a9651ada82dbabf2910b4d84e5 ChangeLog 992
+MD5 d8a1395209625609f78216e7e2694b73 ChangeLog 1080
MD5 2bc2c1a19b506f36a6c0736c01496418 speedtouch-1.1.ebuild 2100
-MD5 6854d8b34a2e5f43fe1fabb5d909435c speedtouch-1.2_beta1.ebuild 2173
+MD5 ecdd063a3f0797e30f9757c923cef118 speedtouch-1.2_beta1.ebuild 2196
MD5 5b5027245babfea9e7dfaee4a1a82af9 files/adsl.sample 501
MD5 c622ee14e155b3897e6a069306d1c88b files/digest-speedtouch-1.1 67
MD5 9c89baff861a43250255b1db0e5c1f6f files/speedtouch.confd 355
diff --git a/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1 b/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1
new file mode 100644
index 000000000000..6264e90614b1
--- /dev/null
+++ b/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1
@@ -0,0 +1 @@
+MD5 a59dc82461ab170e1a55d08461bd895a speedtouch-1.2-beta1.tar.bz2 168793
diff --git a/net-dialup/speedtouch/speedtouch-1.2_beta1.ebuild b/net-dialup/speedtouch/speedtouch-1.2_beta1.ebuild
new file mode 100644
index 000000000000..4d7385693c98
--- /dev/null
+++ b/net-dialup/speedtouch/speedtouch-1.2_beta1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.2_beta1.ebuild,v 1.1 2003/05/26 01:21:35 lu_zero Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="GPL Driver for the Alcatel Speedtouch USB under *nix"
+P=${P/_/-}
+SRC_URI="mirror://sourceforge/speedtouch/${P}.tar.bz2"
+
+HOMEPAGE="http://speedtouch.sf.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~hppa"
+
+DEPEND=""
+RDEPEND=">=net-dialup/ppp-2.4.1"
+
+filter-flags -mpowerpc-gfxopt -mpowerpc-gpopt
+
+src_compile() {
+ local myconf
+
+ [ "${DEBUG:+set}" = set ] && myconf="--enable-debug"
+ use static && myconf="${myconf} --enable-static"
+
+ sed 's/^C$/#&/' < configure > configure.new
+ mv --force configure.new configure && chmod u+x configure
+
+ econf --enable-syslog \
+ ${myconf} || die "./configure failed"
+
+ #sed '90,104d' < Makefile > Makefile.new
+ #mv --force Makefile.new Makefile
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die
+
+ echo $(find ${D}/usr/share/doc/speedtouch/ -type f) | xargs dodoc
+ rm -rf ${D}/usr/share/doc/speedtouch/
+ dodoc AUTHORS COPYING ChangeLog INSTALL TODO VERSION
+ rm -r ${D}/etc/init.d/speedtouch
+ exeinto /etc/init.d ; newexe ${FILESDIR}/speedtouch.rc6 speedtouch
+ insinto /etc/conf.d ; newins ${FILESDIR}/speedtouch.confd speedtouch
+ insopts -m 600 ; insinto /etc/ppp/peers ; doins ${FILESDIR}/adsl.sample
+}
+
+pkg_postinst() {
+ echo ""
+ ewarn "Make sure you have kernel support for USB, HDCL and PPP"
+ ewarn "NB: kernels >= 2.4.18 include the hdlc patch"
+ echo ""
+ ewarn "Read and subscribe vendor's licence to download the microcode"
+ ewarn "You can get it from: "
+ ewarn " 1) vendor's site: http://www.speedtouchdsl.com/dvrreg_lx.htm"
+ ewarn " 2) a windows system: c:\windows\system\alcaudsl.sys"
+ ewarn " 3) the CD provided: X:\Driver\alcaudsl.sys"
+ ewarn "Then you should set its path in the /etc/conf.d/speedtouch file"
+ ewarn "edit and rename 'adsl.sample' to 'adsl' in /etc/ppp/peers/adsl and"
+ ewarn "bring up your adsl line using the /etc/init.d/speedtouch script"
+ echo ""
+ einfo "More info in the documentation in /usr/share/doc/${P}"
+ echo ""
+}