summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-01 17:54:45 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-01 17:54:45 +0000
commit520e89d47e331607ec6d71053daaf71facb052b4 (patch)
tree0037b3ef63e553092701089158d2380c1ee5f00d /net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild
parentstable amd64 (diff)
downloadgentoo-2-520e89d47e331607ec6d71053daaf71facb052b4.tar.gz
gentoo-2-520e89d47e331607ec6d71053daaf71facb052b4.tar.bz2
gentoo-2-520e89d47e331607ec6d71053daaf71facb052b4.zip
taint check (#81880)
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild')
-rw-r--r--net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild b/net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..231adeecf37e
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.5.0-r2.ebuild,v 1.1 2005/04/01 17:54:45 mrness Exp $
+
+MY_P=pptp-linux-${PV}
+MY_CMD=pptp-command-20050401
+
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
+ mirror://gentoo/${MY_CMD}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 ~alpha"
+IUSE="tcltk"
+
+DEPEND=">=net-dialup/ppp-2.4.2
+ dev-lang/perl
+ tcltk? ( dev-perl/perl-tk )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dosbin pptp
+ dodoc AUTHORS COPYING ChangeLog DEVELOPERS NEWS README TODO USING
+ dodoc Documentation/*
+ dodoc Reference/*
+ dodir /etc/pptp.d
+
+ # The current version of pptp-linux doesn't include the
+ # RH-specific portions, so include them ourselves.
+ cd ${FILESDIR}
+ insinto /etc/ppp
+ doins new-mppe/options.pptp
+ newsbin ${WORKDIR}/${MY_CMD} pptp-command
+ dosbin pptp_fe.pl
+ use tcltk && dosbin xpptp_fe.pl
+}