summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-02 16:45:05 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-02 16:45:05 +0000
commitb0824876799dc41583df1271a8b5694f3917cdbf (patch)
treec903225149dfd44771e57ada0f4dbf4aa94bd9b0 /net-dialup/mgetty
parentStable for sh, wrt bug #458122 (diff)
downloadgentoo-2-b0824876799dc41583df1271a8b5694f3917cdbf.tar.gz
gentoo-2-b0824876799dc41583df1271a8b5694f3917cdbf.tar.bz2
gentoo-2-b0824876799dc41583df1271a8b5694f3917cdbf.zip
Fix sed's paths in src_prepare, fix problem with doc building and installation wrt bug #459906. Thanks to Juergen Rose for discovering this issue
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup/mgetty')
-rw-r--r--net-dialup/mgetty/ChangeLog7
-rw-r--r--net-dialup/mgetty/mgetty-1.1.37.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/net-dialup/mgetty/ChangeLog b/net-dialup/mgetty/ChangeLog
index 07e7158e5492..452f59db0ce1 100644
--- a/net-dialup/mgetty/ChangeLog
+++ b/net-dialup/mgetty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/mgetty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.103 2013/02/24 22:14:10 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.104 2013/03/02 16:45:05 pinkbyte Exp $
+
+ 02 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> mgetty-1.1.37.ebuild:
+ Fix sed's paths in src_prepare, fix problem with doc building and
+ installation wrt bug #459906. Thanks to Juergen Rose for discovering this
+ issue
*mgetty-1.1.37 (24 Feb 2013)
diff --git a/net-dialup/mgetty/mgetty-1.1.37.ebuild b/net-dialup/mgetty/mgetty-1.1.37.ebuild
index e018d2bf5e62..b86ca2fff385 100644
--- a/net-dialup/mgetty/mgetty-1.1.37.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.37.ebuild,v 1.1 2013/02/24 22:14:10 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.37.ebuild,v 1.2 2013/03/02 16:45:05 pinkbyte Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs user
@@ -44,16 +44,18 @@ src_prepare() {
-e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
-e 's:\/\* \(\#define CNDFILE "dialin.config"\) \*\/:\1:' \
-e 's:\(\#define FAX_NOTIFY_PROGRAM\).*:\1 "/etc/mgetty+sendfax/new_fax":' \
- "${S}/policy.h-dist" > "${S}/policy.h" || die 'creating policy.h failed'
+ policy.h-dist > policy.h || die 'creating policy.h failed'
sed -i -e 's:/usr/local/lib/mgetty+sendfax:/etc/mgetty+sendfax:' faxrunq.config || die 'changing mgetty config dir failed'
sed -i -e 's:/usr/local/bin/g3cat:/usr/bin/g3cat:' faxrunq.config fax/faxspool.rules || die 'changing g3cat path failed'
sed -e "/^doc-all:/s/mgetty.asc mgetty.info mgetty.dvi mgetty.ps/mgetty.info/" \
- -i "${S}/doc/Makefile" || die 'first sed on doc/Makefile failed'
+ -i doc/Makefile || die 'first sed on doc/Makefile failed'
if use doc; then
- sed -e "s/^doc-all:/doc-all: mgetty.ps/" \
- -i "${S}/doc/Makefile" || die 'second sed on doc/Makefile failed'
+ sed -i \
+ -e "s/^doc-all:/doc-all: mgetty.ps/" \
+ -e "s/^all:/all: doc-all/" \
+ doc/Makefile || die 'second sed on doc/Makefile failed'
fi
}