summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-16 23:01:16 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-16 23:01:16 +0000
commite6d0ecd3af1ce9854d397f9ae61977b894d0a7db (patch)
tree48965938e3cdbd7014291c7ac0596a6513a6ae67 /net-dialup/isdn4k-utils
parent~alpha updates (diff)
downloadgentoo-2-e6d0ecd3af1ce9854d397f9ae61977b894d0a7db.tar.gz
gentoo-2-e6d0ecd3af1ce9854d397f9ae61977b894d0a7db.tar.bz2
gentoo-2-e6d0ecd3af1ce9854d397f9ae61977b894d0a7db.zip
new release to fix bugs found in the ebuild (no bug #'s for them)
Diffstat (limited to 'net-dialup/isdn4k-utils')
-rw-r--r--net-dialup/isdn4k-utils/ChangeLog15
-rw-r--r--net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1-r1 (renamed from net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1)0
-rw-r--r--net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1-r1.ebuild58
-rw-r--r--net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1.ebuild62
4 files changed, 68 insertions, 67 deletions
diff --git a/net-dialup/isdn4k-utils/ChangeLog b/net-dialup/isdn4k-utils/ChangeLog
index bc6cdae2ea63..5b7c4ffa2ab0 100644
--- a/net-dialup/isdn4k-utils/ChangeLog
+++ b/net-dialup/isdn4k-utils/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for net-dialup/isdn4k-utils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/ChangeLog,v 1.2 2002/08/09 00:28:34 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/ChangeLog,v 1.3 2002/12/16 23:01:16 drobbins Exp $
-*isdn4k-utils-3.2_p1 (9 Aug 2002)
+*isdn4k-utils-3.2_p1-r1 (12 Dec 2002)
+
+ 16 Dec 2002; Daniel Robbins <drobbins@gentoo.org> : new rev. Docs install in
+ the correct place, and device nodes are no longer created (devfs should take
+ care of this.)
- 9 Aug 2002; Bart Verwilst <verwilst@gentoo.org> :
+*isdn4k-utils-3.2_p1 (9 Aug 2002)
- New working version, just in time for our Gentoo 1.4 release :o)
- This version will be included on our bootcd.
+ 9 Aug 2002; Bart Verwilst <verwilst@gentoo.org> : New working version, just
+ in time for our Gentoo 1.4 release :o) This version will be included on our
+ bootcd.
*isdn4k-utils-3.1_p1-r3 (16 Jul 2002)
diff --git a/net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1 b/net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1-r1
index 6b0b9b465e32..6b0b9b465e32 100644
--- a/net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1
+++ b/net-dialup/isdn4k-utils/files/digest-isdn4k-utils-3.2_p1-r1
diff --git a/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1-r1.ebuild b/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1-r1.ebuild
new file mode 100644
index 000000000000..4b1d85a2922c
--- /dev/null
+++ b/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1-r1.ebuild,v 1.1 2002/12/16 23:01:16 drobbins Exp $
+
+IUSE="mysql"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="ISDN-4-Linux Utils"
+SRC_URI="ftp://ftp.isdn4linux.de/pub/isdn4linux/utils/${PN}.v3.2p1.tar.bz2"
+HOMEPAGE="http://www.isdn4linux.de/"
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=virtual/linux-sources-2.4
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/gdbm-1.8.0
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ >=dev-lang/tk-8.3"
+
+
+src_unpack() {
+ unpack ${PN}.v3.2p1.tar.bz2
+ cd ${S}
+ cp ${FILESDIR}/${P}.config .config
+ #disabling device creation the easy way:
+ echo "#!/bin/bash" > scripts/makedev.sh
+ echo "true" >> scripts/makedev.sh
+}
+
+src_compile() {
+ cd ${S}
+ make subconfig || die
+ make || die
+}
+
+src_install() {
+ cd ${S}
+ dodir /dev
+ dodir /usr/sbin
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING NEWS README Mini-FAQ/isdn-faq.txt
+ mv ${D}/usr/doc/vbox ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/doc ${D}/dev
+ cp -f ${FILESDIR}/local.start ${D}/usr/share/doc/${PF}/local.start
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please remember to edit your /etc/modules.autoload to load your ISDN kernel modules."
+ einfo "Also make sure to edit the /etc/isdn/* files and configure them correctly. "
+ einfo "In /usr/share/doc/${PF} you can find an local.start example, which shows how to"
+ einfo "start some utils."
+ einfo
+}
diff --git a/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1.ebuild b/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1.ebuild
deleted file mode 100644
index b7a2027c51ae..000000000000
--- a/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/isdn4k-utils-3.2_p1.ebuild,v 1.3 2002/10/05 05:39:18 drobbins Exp $
-
-IUSE="mysql"
-
-S=${WORKDIR}/${PN}
-DESCRIPTION="ISDN-4-Linux Utils"
-SRC_URI="ftp://ftp.isdn4linux.de/pub/isdn4linux/utils/${PN}.v3.2p1.tar.bz2"
-HOMEPAGE="http://www.isdn4linux.de/"
-SLOT="0"
-KEYWORDS="x86"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc
- >=virtual/linux-sources-2.4
- >=sys-libs/ncurses-5.1
- >=sys-libs/gdbm-1.8.0
- mysql? ( >=dev-db/mysql-3.23.26 )
- >=dev-lang/tk-8.3"
-
-
-src_unpack() {
-
- unpack ${PN}.v3.2p1.tar.bz2
- cd ${S}
- cp ${FILESDIR}/${P}.config .config
-
-}
-
-src_compile() {
-
- cd ${S}
- make subconfig || die
- make || die
-
-}
-
-src_install() {
-
- cd ${S}
- dodir /dev
- dodir /usr/sbin
- dodir /usr/bin
- make DESTDIR=${D} install || die
-
- dodoc COPYING NEWS README Mini-FAQ/isdn-faq.txt
- mv ${D}/usr/doc/vbox ${D}/usr/doc/${P}
-
- cp -f ${FILESDIR}/local.start ${D}/usr/doc/${P}/local.start
-
-}
-
-pkg_postinst() {
-
- einfo
- einfo "Please remember to edit your /etc/modules.autoload to load the ISDN kernel modules !!"
- einfo "Also make sure to edit the /etc/isdn/* files. "
- einfo "In /usr/doc/${P} you can find an local.start example, which shows how to start some utils."
- einfo
-
-}