summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-03-13 20:47:50 +0000
committerAlin Năstac <mrness@gentoo.org>2009-03-13 20:47:50 +0000
commit2a841e87170e48fc0ec8eb1e4b6bdc9efd40c7bd (patch)
treeece0390a4ae4427e19ad1aef4c2ec40f83de9a3c /net-dialup/hcfusbmodem
parentCleanup (diff)
downloadgentoo-2-2a841e87170e48fc0ec8eb1e4b6bdc9efd40c7bd.tar.gz
gentoo-2-2a841e87170e48fc0ec8eb1e4b6bdc9efd40c7bd.tar.bz2
gentoo-2-2a841e87170e48fc0ec8eb1e4b6bdc9efd40c7bd.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/hcfusbmodem')
-rw-r--r--net-dialup/hcfusbmodem/ChangeLog8
-rw-r--r--net-dialup/hcfusbmodem/files/hcfusbmodem-1.18-gentoo.patch29
-rw-r--r--net-dialup/hcfusbmodem/hcfusbmodem-1.18.ebuild50
3 files changed, 86 insertions, 1 deletions
diff --git a/net-dialup/hcfusbmodem/ChangeLog b/net-dialup/hcfusbmodem/ChangeLog
index 359c4a0193cc..b8559cb350f0 100644
--- a/net-dialup/hcfusbmodem/ChangeLog
+++ b/net-dialup/hcfusbmodem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/hcfusbmodem
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/ChangeLog,v 1.30 2009/01/12 22:33:42 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/ChangeLog,v 1.31 2009/03/13 20:47:50 mrness Exp $
+
+*hcfusbmodem-1.18 (13 Mar 2009)
+
+ 13 Mar 2009; Alin Năstac <mrness@gentoo.org>
+ +files/hcfusbmodem-1.18-gentoo.patch, +hcfusbmodem-1.18.ebuild:
+ Version bump.
12 Jan 2009; Alin Năstac <mrness@gentoo.org> -hcfusbmodem-1.15.ebuild:
Drop obsolete revision.
diff --git a/net-dialup/hcfusbmodem/files/hcfusbmodem-1.18-gentoo.patch b/net-dialup/hcfusbmodem/files/hcfusbmodem-1.18-gentoo.patch
new file mode 100644
index 000000000000..dab9a7df6f1a
--- /dev/null
+++ b/net-dialup/hcfusbmodem/files/hcfusbmodem-1.18-gentoo.patch
@@ -0,0 +1,29 @@
+diff -Nru hcfusbmodem-1.18powerpcfull.orig/diag/makefile hcfusbmodem-1.18powerpcfull/diag/makefile
+--- hcfusbmodem-1.18powerpcfull.orig/diag/makefile 2004-12-14 07:50:41.000000000 +0000
++++ hcfusbmodem-1.18powerpcfull/diag/makefile 2009-03-13 20:44:53.000000000 +0000
+@@ -10,7 +10,7 @@
+ include $(TOP)/config.mak
+ -include $(TOP)/modules/imported/makeflags.mak
+
+-CFLAGS = -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
++CFLAGS += -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
+ CFLAGS += $(IMPORTED_FRAMEWORK_DEFS) $(IMPORTED_GENERAL_DEFS)
+ CFLAGS += -DCNXTTARGET="\"$(CNXTTARGET)\""
+
+@@ -41,13 +41,13 @@
+ $(MKDIR) -p $@
+
+ $(CNXTTARGET)diag: diag.o modemexpert.o
+- $(CC) -o $@ $^
++ $(CC) ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)scr: scr.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)dmp: dmp.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ clean:
+ rm -f *.o $(ALL)
diff --git a/net-dialup/hcfusbmodem/hcfusbmodem-1.18.ebuild b/net-dialup/hcfusbmodem/hcfusbmodem-1.18.ebuild
new file mode 100644
index 000000000000..8647710ff2e1
--- /dev/null
+++ b/net-dialup/hcfusbmodem/hcfusbmodem-1.18.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/hcfusbmodem-1.18.ebuild,v 1.1 2009/03/13 20:47:50 mrness Exp $
+
+inherit linux-info eutils
+
+DESCRIPTION="hcfusbmodem - Modem driver for Connexant HSF chipset"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}powerpcfull.tar.gz"
+HOMEPAGE="http://www.linuxant.com/drivers/"
+
+IUSE=""
+SLOT="0"
+LICENSE="Conexant"
+KEYWORDS="-* ~ppc"
+
+DEPEND="dev-lang/perl
+ app-arch/cpio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}powerpcfull"
+
+QA_EXECSTACK="usr/lib/hcfusbmodem/modules/imported/hcfblam-powerpc.O usr/lib/hcfusbmodem/modules/imported/hcfengine-powerpc.O"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake all || die "make failed"
+}
+
+src_install () {
+ make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]; then
+ elog "To complete the installation and configuration of your HCF modem,"
+ elog "please run hcfusbconfig."
+ fi
+}
+
+pkg_prerm() {
+ if [ "${ROOT}" = / -a -f /etc/init.d/hcfusb ] ; then
+ hcfusbconfig --remove || die "hcfusbconfig --remove failed"
+ fi
+}