summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-03-26 17:32:20 +0000
committerAlin Năstac <mrness@gentoo.org>2006-03-26 17:32:20 +0000
commit3227b48558f5f8e67697448b78a2c6f25cb559f4 (patch)
tree113e79692751aed7b1cf799aa7143f5eb93481c1 /net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild
parentMark 3.4.3 stable on ia64 (diff)
downloadgentoo-2-3227b48558f5f8e67697448b78a2c6f25cb559f4.tar.gz
gentoo-2-3227b48558f5f8e67697448b78a2c6f25cb559f4.tar.bz2
gentoo-2-3227b48558f5f8e67697448b78a2c6f25cb559f4.zip
Bail out in pkg_setup if kernel version is >=2.6.16. This kernel version contains a driver for eagle-usb ADSL modems (#127528).
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild')
-rw-r--r--net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild b/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild
index eb314bf40de3..9dd4235371ce 100644
--- a/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild
+++ b/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild,v 1.1 2006/03/12 10:34:51 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild,v 1.2 2006/03/26 17:32:20 mrness Exp $
inherit linux-mod eutils
@@ -20,6 +20,16 @@ CONFIG_CHECK="!IPV6 USB"
BUILD_TARGETS=" "
BUILD_PARAMS="KERNELSRC='${KV_DIR}'"
+pkg_setup() {
+ if kernel_is ge 2 6 16; then
+ eerror "This driver should be used only with kernel versions less than 2.6.16."
+ eerror "Please install and use the driver included in your kernel instead."
+ eerror "The kernel option that enables the driver is CONFIG_USB_UEAGLEATM."
+ die "unsupported kernel version"
+ fi
+ linux-mod_pkg_setup
+}
+
src_unpack() {
unpack ${A}