summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-03 09:43:19 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-03 09:43:19 +0000
commitec340260c0f2677bd62c13461ed07fcb2158a465 (patch)
treed0636a4ac855c5d3419452b4d4b02603011899e9 /net-analyzer
parentMask java and ruby kdebinding wrt #280629 and #353538 (diff)
downloadgentoo-2-ec340260c0f2677bd62c13461ed07fcb2158a465.tar.gz
gentoo-2-ec340260c0f2677bd62c13461ed07fcb2158a465.tar.bz2
gentoo-2-ec340260c0f2677bd62c13461ed07fcb2158a465.zip
Respect CC, moved to EAPI=3
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nettop/ChangeLog9
-rw-r--r--net-analyzer/nettop/nettop-0.2.3-r2.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/net-analyzer/nettop/ChangeLog b/net-analyzer/nettop/ChangeLog
index 93e7a7286f4f..302d5aabd750 100644
--- a/net-analyzer/nettop/ChangeLog
+++ b/net-analyzer/nettop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nettop
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.19 2010/09/20 00:31:45 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.20 2011/02/03 09:43:19 jlec Exp $
+
+*nettop-0.2.3-r2 (03 Feb 2011)
+
+ 03 Feb 2011; Justin Lecher <jlec@gentoo.org> +nettop-0.2.3-r2.ebuild:
+ Respect CC, moved to EAPI=3
20 Sep 2010; Michael Weber <xmw@gentoo.org> nettop-0.2.3-r1.ebuild:
Added ~arm keyword
diff --git a/net-analyzer/nettop/nettop-0.2.3-r2.ebuild b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..749a6791b7e7
--- /dev/null
+++ b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3-r2.ebuild,v 1.1 2011/02/03 09:43:19 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="top like program for network activity"
+SRC_URI="http://srparish.net/scripts/${P}.tar.gz"
+HOMEPAGE="http://srparish.net/software/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/slang
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ewarn "This is known to break with distcc, see bug #169245 for details"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc411.patch \
+ "${FILESDIR}"/${P}-offbyone.patch
+ tc-export CC
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=/usr"
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_install() {
+ dosbin nettop || die
+ dodoc ChangeLog README THANKS || die
+}