summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-08-31 15:55:55 +0000
committerJeroen Roovers <jer@gentoo.org>2012-08-31 15:55:55 +0000
commite6e03b6f44fafad20916ff2a49982b5bb2b0c0aa (patch)
treee58a848234519a462660f330e64484c7f273472e /net-analyzer
parentStable channel bump. (diff)
downloadgentoo-2-e6e03b6f44fafad20916ff2a49982b5bb2b0c0aa.tar.gz
gentoo-2-e6e03b6f44fafad20916ff2a49982b5bb2b0c0aa.tar.bz2
gentoo-2-e6e03b6f44fafad20916ff2a49982b5bb2b0c0aa.zip
Simplify aDNS support choices by zerochaos.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/metadata.xml3
-rw-r--r--net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild20
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild19
4 files changed, 28 insertions, 20 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index cbc51fb3c6f1..ee946085bd9e 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.383 2012/08/31 15:41:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.384 2012/08/31 15:55:55 jer Exp $
+
+ 31 Aug 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.6.10-r1.ebuild,
+ wireshark-1.8.2-r1.ebuild, metadata.xml:
+ Simplify aDNS support choices by zerochaos.
31 Aug 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.6.10-r1.ebuild:
Prefer USE=ares.
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index b3d6c07dbbbb..1e42a0437d75 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -35,9 +35,10 @@
</longdescription>
<use>
<flag name='ares'>Use the GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
+<flag name='adns'>Add support for asynchronous DNS</flag>
<flag name='doc-pdf'>Build documentation in pdf format (US and a4 paper sizes)</flag>
<flag name='gcrypt'>Use GNU crypto library (<pkg>dev-libs/libgcrypt</pkg>) to decrypt ipsec traffic</flag>
-<flag name='libadns'>Use the <pkg>net-lib/adns</pkg> library to resolve DNS names</flag>
+<flag name='libadns'>Use <pkg>net-lib/adns</pkg> instead of <pkg>net-dns/c-ares</pkg> to resolve DNS names</flag>
<flag name='pcap'>Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
<flag name='smi'>Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
</use>
diff --git a/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild b/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild
index 63e9ac6df1f1..d9fd603111b8 100644
--- a/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild,v 1.2 2012/08/31 15:41:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.10-r1.ebuild,v 1.3 2012/08/31 15:55:55 jer Exp $
EAPI=4
PYTHON_DEPEND="python? 2"
@@ -15,13 +15,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="
- adns +ares doc doc-pdf gtk ipv6 libadns lua gcrypt geoip kerberos profile
+ adns doc doc-pdf gtk ipv6 libadns lua gcrypt geoip kerberos profile
+pcap portaudio python +caps selinux smi ssl threads zlib
"
-REQUIRED_USE="
- adns? ( ^^ ( ares libadns ) )
- adns? ( || ( ares libadns ) )
-"
RDEPEND=">=dev-libs/glib-2.14:2
zlib? ( sys-libs/zlib
@@ -38,7 +34,7 @@ RDEPEND=">=dev-libs/glib-2.14:2
kerberos? ( virtual/krb5 )
portaudio? ( media-libs/portaudio )
adns? (
- ares? ( >=net-dns/c-ares-1.5 )
+ !libadns? ( >=net-dns/c-ares-1.5 )
libadns? ( net-libs/adns )
)
geoip? ( dev-libs/geoip )
@@ -134,6 +130,14 @@ src_configure() {
append-flags $(test-flags-CC -nopie)
fi
+ if use adns; then
+ if use libadns; then
+ myconf+="--with-adns --without-c-ares"
+ else
+ myconf+="--without-adns --with-c-ares"
+ fi
+ fi
+
# Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
# --with-ssl to ./configure. (Mimics code from acinclude.m4).
if use kerberos; then
@@ -159,12 +163,10 @@ src_configure() {
$(use_enable ipv6) \
$(use_enable profile profile-build) \
$(use_enable threads) \
- $(use_with ares c-ares) \
$(use_with caps libcap) \
$(use_with gcrypt) \
$(use_with geoip) \
$(use_with kerberos krb5) \
- $(use_with libadns adns) \
$(use_with lua) \
$(use_with pcap dumpcap-group wireshark) \
$(use_with pcap) \
diff --git a/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild b/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild
index 049efcf26dad..7b314e7f4037 100644
--- a/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild,v 1.1 2012/08/31 15:26:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r1.ebuild,v 1.2 2012/08/31 15:55:55 jer Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -15,13 +15,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="
- adns +ares doc doc-pdf gtk ipv6 libadns lua gcrypt geoip kerberos profile
+ adns doc doc-pdf gtk ipv6 libadns lua gcrypt geoip kerberos profile
+pcap portaudio python +caps selinux smi ssl zlib
"
-REQUIRED_USE="
- adns? ( ^^ ( ares libadns ) )
- adns? ( || ( ares libadns ) )
-"
RDEPEND=">=dev-libs/glib-2.14:2
zlib? ( sys-libs/zlib
@@ -38,7 +34,7 @@ RDEPEND=">=dev-libs/glib-2.14:2
kerberos? ( virtual/krb5 )
portaudio? ( media-libs/portaudio )
adns? (
- ares? ( >=net-dns/c-ares-1.5 )
+ !libadns? ( >=net-dns/c-ares-1.5 )
libadns? ( net-libs/adns )
)
geoip? ( dev-libs/geoip )
@@ -132,6 +128,13 @@ src_configure() {
append-flags $(test-flags-CC -nopie)
fi
+ if use adns; then
+ if use libadns; then
+ myconf+="--with-adns --without-c-ares"
+ else
+ myconf+="--without-adns --with-c-ares"
+ fi
+ fi
# Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
# --with-ssl to ./configure. (Mimics code from acinclude.m4).
if use kerberos; then
@@ -156,12 +159,10 @@ src_configure() {
$(use_enable gtk wireshark) \
$(use_enable ipv6) \
$(use_enable profile profile-build) \
- $(use_with ares c-ares) \
$(use_with caps libcap) \
$(use_with gcrypt) \
$(use_with geoip) \
$(use_with kerberos krb5) \
- $(use_with libadns adns) \
$(use_with lua) \
$(use_with pcap dumpcap-group wireshark) \
$(use_with pcap) \