summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-04-30 15:21:33 +0000
committerJeroen Roovers <jer@gentoo.org>2012-04-30 15:21:33 +0000
commitaec7555f89b27e2fa51838152d531c958423589e (patch)
tree15bb9982aa09b991bcbaeb17f781d99556ec095b /net-analyzer
parentFix nodoctargz patch for latest source, bug #413111 (diff)
downloadgentoo-2-aec7555f89b27e2fa51838152d531c958423589e.tar.gz
gentoo-2-aec7555f89b27e2fa51838152d531c958423589e.tar.bz2
gentoo-2-aec7555f89b27e2fa51838152d531c958423589e.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sguil-client/ChangeLog7
-rw-r--r--net-analyzer/sguil-client/sguil-client-0.8.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/net-analyzer/sguil-client/ChangeLog b/net-analyzer/sguil-client/ChangeLog
index de96783f741c..6112ece17fec 100644
--- a/net-analyzer/sguil-client/ChangeLog
+++ b/net-analyzer/sguil-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/sguil-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/ChangeLog,v 1.10 2012/04/30 15:17:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/ChangeLog,v 1.11 2012/04/30 15:21:33 jer Exp $
+
+*sguil-client-0.8.0 (30 Apr 2012)
+
+ 30 Apr 2012; Jeroen Roovers <jer@gentoo.org> +sguil-client-0.8.0.ebuild:
+ Version bump.
30 Apr 2012; Jeroen Roovers <jer@gentoo.org> sguil-client-0.6.1.ebuild:
Install everything in client/lib. Remove sed script by Greg Watson (bug
diff --git a/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild b/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild
new file mode 100644
index 000000000000..f6da71121353
--- /dev/null
+++ b/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild,v 1.1 2012/04/30 15:21:33 jer Exp $
+
+EAPI=4
+inherit multilib
+
+MY_PV="${PV/_p/p}"
+DESCRIPTION="GUI Console for sguil Network Security Monitoring"
+HOMEPAGE="http://sguil.sf.net"
+SRC_URI="mirror://sourceforge/sguil/sguil-client-${MY_PV}.tar.gz"
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-lang/tcl-8.3[-threads]
+ >=dev-lang/tk-8.3
+ >=dev-tcltk/itcl-3.2
+ >=dev-tcltk/tclx-8.3
+ dev-tcltk/itk
+ dev-tcltk/iwidgets
+ dev-tcltk/tcllib
+ ssl? ( >=dev-tcltk/tls-1.4.1 )
+ net-analyzer/wireshark"
+
+S="${WORKDIR}/sguil-${MY_PV}"
+
+src_prepare() {
+ sed -i client/sguil.conf \
+ -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
+ -e '/^set ETHEREAL_PATH /s:/usr/sbin/ethereal:/usr/bin/wireshark:' \
+ -e '/^set SERVERHOST /s:demo.sguil.net:localhost:' \
+ -e '/^set MAILSERVER /s:mail.example.com:localhost:' \
+ -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' || die
+}
+
+src_install() {
+ dobin client/sguil.tk
+ insinto /etc/sguil
+ doins client/sguil.conf
+ insinto "/usr/$(get_libdir)/sguil"
+ doins -r "${S}"/client/lib/*
+ dodoc doc/*
+}