summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-08-14 11:57:25 +0000
committerJustin Lecher <jlec@gentoo.org>2011-08-14 11:57:25 +0000
commita6f8a98243a7b7dc085aae1a4fbad345741d9cf4 (patch)
treec6b0243b25764c038f30d73860848008ed414cc1 /net-analyzer
parentMake the perl bindings actually install; things should be compiled during the... (diff)
downloadgentoo-2-a6f8a98243a7b7dc085aae1a4fbad345741d9cf4.tar.gz
gentoo-2-a6f8a98243a7b7dc085aae1a4fbad345741d9cf4.tar.bz2
gentoo-2-a6f8a98243a7b7dc085aae1a4fbad345741d9cf4.zip
Version Bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 2b20f294fce0..310339ec1fd5 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.57 2011/08/08 17:14:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.58 2011/08/14 11:57:25 jlec Exp $
+
+*linkchecker-7.1 (14 Aug 2011)
+
+ 14 Aug 2011; Justin Lecher <jlec@gentoo.org> +linkchecker-7.1.ebuild:
+ Version Bump
08 Aug 2011; Markos Chandras <hwoarang@gentoo.org> linkchecker-7.0.ebuild:
Restrict 2.4 and 2.5 Python ABIs. Update HOMEPAGE. Patch by Arfrever.
diff --git a/net-analyzer/linkchecker/linkchecker-7.1.ebuild b/net-analyzer/linkchecker/linkchecker-7.1.ebuild
new file mode 100644
index 000000000000..82c11d852265
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.1.ebuild,v 1.1 2011/08/14 11:57:25 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/5.2-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ delete_gui() {
+ if ! use X; then
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ fi
+ }
+ python_execute_function -q delete_gui
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+ use bash-completion && dobashcompletion config/linkchecker-completion
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ echo ""
+ distutils_pkg_postinst
+}