summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-19 14:33:39 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-19 14:33:39 +0000
commit9dcbe943ce4f5176c8ddd692946caf46dd94bdf7 (patch)
treece5c9455f860ecdfd420689d833bf2de1da603a6 /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-9dcbe943ce4f5176c8ddd692946caf46dd94bdf7.tar.gz
gentoo-2-9dcbe943ce4f5176c8ddd692946caf46dd94bdf7.tar.bz2
gentoo-2-9dcbe943ce4f5176c8ddd692946caf46dd94bdf7.zip
Respect LDFLAGS (bug #341767). Make sed die. Set RDEPEND.
(Portage version: 2.2_rc98/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ipband/ChangeLog10
-rw-r--r--net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch10
-rw-r--r--net-analyzer/ipband/ipband-0.8.1-r1.ebuild (renamed from net-analyzer/ipband/ipband-0.8.1.ebuild)18
3 files changed, 24 insertions, 14 deletions
diff --git a/net-analyzer/ipband/ChangeLog b/net-analyzer/ipband/ChangeLog
index f4fc9412a789..fff032018041 100644
--- a/net-analyzer/ipband/ChangeLog
+++ b/net-analyzer/ipband/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ipband
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ChangeLog,v 1.7 2009/01/15 05:38:51 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ChangeLog,v 1.8 2010/10/19 14:33:39 jer Exp $
+
+*ipband-0.8.1-r1 (19 Oct 2010)
+
+ 19 Oct 2010; Jeroen Roovers <jer@gentoo.org> -ipband-0.8.1.ebuild,
+ +ipband-0.8.1-r1.ebuild, files/ipband-0.8.1-gentoo.patch:
+ Respect LDFLAGS (bug #341767). Make sed die. Set RDEPEND.
15 Jan 2009; Jeroen Roovers <jer@gentoo.org>
+files/ipband-0.8.1-gentoo.patch, ipband-0.8.1.ebuild:
diff --git a/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
index 439a6aa36e1b..0a5a39b21489 100644
--- a/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
+++ b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
@@ -1,5 +1,5 @@
---- ipband-0.8.1/Makefile.orig 2008-06-17 19:23:19.000000000 +0200
-+++ ipband-0.8.1/Makefile 2009-01-15 06:33:07.000000000 +0100
+--- Makefile.orig 2008-06-17 19:23:19.000000000 +0200
++++ Makefile 2010-10-19 16:23:35.000000000 +0200
@@ -12,7 +12,6 @@
CPPFLAGS=-I/usr/include/pcap
LIBS=-lpcap
@@ -8,11 +8,13 @@
ifndef PREFIX
PREFIX=/usr
-@@ -50,7 +49,6 @@
+@@ -49,8 +48,7 @@
+ all: $(BIN)
$(BIN): $(OBJ_C)
- $(CC) -o $(BIN) $(OBJ_C) $(LIBS) $(CFLAGS)
+- $(CC) -o $(BIN) $(OBJ_C) $(LIBS) $(CFLAGS)
- strip $(BIN)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ_C) $(LIBS)
install-strip: install
diff --git a/net-analyzer/ipband/ipband-0.8.1.ebuild b/net-analyzer/ipband/ipband-0.8.1-r1.ebuild
index bc3bbf005352..c126d31bead0 100644
--- a/net-analyzer/ipband/ipband-0.8.1.ebuild
+++ b/net-analyzer/ipband/ipband-0.8.1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.1.ebuild,v 1.2 2009/01/15 05:38:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.1-r1.ebuild,v 1.1 2010/10/19 14:33:39 jer Exp $
+
+EAPI="2"
inherit eutils toolchain-funcs
@@ -14,15 +16,15 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=">=net-libs/libpcap-0.4"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# Provide a postfix MTA string in the author's ipband.conf example
- sed -rie 's:(#mtastring.*):# Sendmail\n\1\n# Postfix\n#mtastring "/usr/sbin/sendmail -t":g' \
- "${S}"/ipband.sample.conf
+ sed -ri ipband.sample.conf \
+ -e 's:(#mtastring.*):# Sendmail\n\1\n# Postfix\n#mtastring "/usr/sbin/sendmail -t":g' \
+ || die "sed ipband.sample.conf"
- # Do not strip and do use toolchain
+ # Do not strip, and do respect CC, LDFLAGS
epatch "${FILESDIR}"/${P}-gentoo.patch
}