summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-27 12:22:12 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-27 12:22:12 +0000
commit743deb3f57268ee451aab6b43b225d872e43d4db (patch)
tree4a52e985294f022277de7e1c7f10b6db18222f94 /net-analyzer
parentFix test. Bug #526558 (diff)
downloadgentoo-2-743deb3f57268ee451aab6b43b225d872e43d4db.tar.gz
gentoo-2-743deb3f57268ee451aab6b43b225d872e43d4db.tar.bz2
gentoo-2-743deb3f57268ee451aab6b43b225d872e43d4db.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527046).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/bwmon/ChangeLog6
-rw-r--r--net-analyzer/bwmon/bwmon-1.3-r2.ebuild22
-rw-r--r--net-analyzer/bwmon/files/bwmon-1.3-tinfo.patch11
3 files changed, 28 insertions, 11 deletions
diff --git a/net-analyzer/bwmon/ChangeLog b/net-analyzer/bwmon/ChangeLog
index eba03964c306..1278b000fc48 100644
--- a/net-analyzer/bwmon/ChangeLog
+++ b/net-analyzer/bwmon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/bwmon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/ChangeLog,v 1.28 2014/07/10 19:51:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/ChangeLog,v 1.29 2014/10/27 12:22:12 jer Exp $
+
+ 27 Oct 2014; Jeroen Roovers <jer@gentoo.org> bwmon-1.3-r2.ebuild,
+ +files/bwmon-1.3-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527046).
10 Jul 2014; Jeroen Roovers <jer@gentoo.org> -bwmon-1.3.ebuild,
-bwmon-1.3-r1.ebuild, bwmon-1.3-r2.ebuild, files/bwmon-1.3-build.patch,
diff --git a/net-analyzer/bwmon/bwmon-1.3-r2.ebuild b/net-analyzer/bwmon/bwmon-1.3-r2.ebuild
index 23c7a8d5ac25..7599b8f9146f 100644
--- a/net-analyzer/bwmon/bwmon-1.3-r2.ebuild
+++ b/net-analyzer/bwmon/bwmon-1.3-r2.ebuild
@@ -1,32 +1,34 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/bwmon-1.3-r2.ebuild,v 1.7 2014/07/10 19:51:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/bwmon-1.3-r2.ebuild,v 1.8 2014/10/27 12:22:12 jer Exp $
EAPI=5
-
inherit eutils toolchain-funcs
DESCRIPTION="Simple ncurses bandwidth monitor"
HOMEPAGE="http://bwmon.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DEPEND="sys-libs/ncurses"
-RDEPEND="${DEPEND}"
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
SLOT="0"
LICENSE="GPL-2 public-domain"
KEYWORDS="amd64 hppa ppc sparc x86"
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
- # Fix a typo in help wrt bug #263326
- epatch "${FILESDIR}"/${P}-typo-fix.patch
- # Fix an overflow wrt bug #441420
- epatch "${FILESDIR}"/${P}-overflow.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-typo-fix.patch \
+ "${FILESDIR}"/${P}-overflow.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
}
src_compile() {
- emake -Csrc CC="$(tc-getCC)"
+ emake -C src CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
}
src_install () {
diff --git a/net-analyzer/bwmon/files/bwmon-1.3-tinfo.patch b/net-analyzer/bwmon/files/bwmon-1.3-tinfo.patch
new file mode 100644
index 000000000000..df0bb06cb968
--- /dev/null
+++ b/net-analyzer/bwmon/files/bwmon-1.3-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -11,7 +11,7 @@
+ INSTALL = install
+
+ CFLAGS += -I../include -Wall -D__THREADS
+-LIBS = -lpthread -lncurses
++LIBS = -lpthread $(shell ${PKG_CONFIG} --libs ncurses)
+
+ SRC = bwmon.c
+ OBJS = $(SRC:.c=.o)