summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 23:04:20 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 23:04:20 +0000
commit6c2aef8997d078d89666448766a5678ef13b0015 (patch)
tree356cbd50933c59789859b7edb3cdc2dbb6c1f1e1 /net-analyzer
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-6c2aef8997d078d89666448766a5678ef13b0015.tar.gz
gentoo-2-6c2aef8997d078d89666448766a5678ef13b0015.tar.bz2
gentoo-2-6c2aef8997d078d89666448766a5678ef13b0015.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/metadata.xml1
-rw-r--r--net-analyzer/wireshark/wireshark-1.99.1.ebuild6
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild6
4 files changed, 11 insertions, 8 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 52bc5484aca2..645ff41c08ad 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.692 2015/01/20 08:17:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.693 2015/01/28 23:04:20 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> metadata.xml,
+ wireshark-1.99.1.ebuild, wireshark-99999999.ebuild:
+ Switch to CPU_FLAGS_X86.
20 Jan 2015; Jeroen Roovers <jer@gentoo.org> wireshark-99999999.ebuild:
Drop obsolete patch.
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index 6ace076e652f..2707e563ea6a 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -34,6 +34,5 @@
<flag name='qt4'>Build the wireshark executable with an experimental Qt UI instead of GTK+.</flag>
<flag name='sbc'>Use <pkg>media-libs/sbc</pkg> for playing back SBC encoded packets</flag>
<flag name='smi'>Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
-<flag name='sse4_2'> Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-1.99.1.ebuild b/net-analyzer/wireshark/wireshark-1.99.1.ebuild
index a8beb3438409..ef36b4421000 100644
--- a/net-analyzer/wireshark/wireshark-1.99.1.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.99.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.99.1.ebuild,v 1.3 2015/01/13 10:35:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.99.1.ebuild,v 1.4 2015/01/28 23:04:20 mgorny Exp $
EAPI=5
inherit autotools eutils fcaps multilib qt4-r2 user
@@ -14,7 +14,7 @@ SLOT="0/${PV}"
KEYWORDS=""
IUSE="
adns +caps crypt doc doc-pdf geoip +gtk3 ipv6 kerberos lua +netlink +pcap
- portaudio +qt4 qt5 selinux sbc smi sse4_2 ssl zlib
+ portaudio +qt4 qt5 selinux sbc smi cpu_flags_x86_sse4_2 ssl zlib
"
REQUIRED_USE="
ssl? ( crypt )
@@ -157,7 +157,7 @@ src_configure() {
$(use_with ssl gnutls) \
$(use_with zlib) \
$(usex netlink --with-libnl=3 --without-libnl) \
- $(usex sse4_2 --enable-sse4_2 '') \
+ $(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
--disable-profile-build \
--disable-usr-local \
--disable-warnings-as-errors \
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 90d8b617057f..408e3fd263f7 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-99999999.ebuild,v 1.7 2015/01/20 08:17:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-99999999.ebuild,v 1.8 2015/01/28 23:04:20 mgorny Exp $
EAPI=5
inherit autotools eutils fcaps git-r3 multilib qt4-r2 user
@@ -14,7 +14,7 @@ SLOT="0/${PV}"
KEYWORDS=""
IUSE="
adns +caps crypt doc doc-pdf geoip +gtk3 ipv6 kerberos lua +netlink +pcap
- portaudio +qt4 qt5 sbc selinux smi sse4_2 ssl zlib
+ portaudio +qt4 qt5 sbc selinux smi cpu_flags_x86_sse4_2 ssl zlib
"
REQUIRED_USE="
ssl? ( crypt )
@@ -160,7 +160,7 @@ src_configure() {
$(use_with ssl gnutls) \
$(use_with zlib) \
$(usex netlink --with-libnl=3 --without-libnl) \
- $(usex sse4_2 --enable-sse4_2 '') \
+ $(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
--disable-profile-build \
--disable-usr-local \
--disable-warnings-as-errors \