summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-05-03 15:09:55 +0000
committerJeroen Roovers <jer@gentoo.org>2012-05-03 15:09:55 +0000
commit319842bca13c77ed696132ffdaec3ccd7f55f188 (patch)
tree8313b0180788930afceff01abe184ec345a1f650 /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-319842bca13c77ed696132ffdaec3ccd7f55f188.tar.gz
gentoo-2-319842bca13c77ed696132ffdaec3ccd7f55f188.tar.bz2
gentoo-2-319842bca13c77ed696132ffdaec3ccd7f55f188.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-1.5.3.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index a16659ba7d93..204934496c72 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.75 2012/03/07 20:51:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.76 2012/05/03 15:09:55 jer Exp $
+
+*httping-1.5.3 (03 May 2012)
+
+ 03 May 2012; Jeroen Roovers <jer@gentoo.org> +httping-1.5.3.ebuild:
+ Version bump.
07 Mar 2012; Jeroen Roovers <jer@gentoo.org> -httping-1.4.4.ebuild:
Old.
diff --git a/net-analyzer/httping/httping-1.5.3.ebuild b/net-analyzer/httping/httping-1.5.3.ebuild
new file mode 100644
index 000000000000..7c5c0ac64be6
--- /dev/null
+++ b/net-analyzer/httping/httping-1.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.3.ebuild,v 1.1 2012/05/03 15:09:55 jer Exp $
+
+EAPI=4
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND=">=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ $(use ssl && echo SSL=yes || echo SSL=no) \
+ $(use debug && echo DEBUG=yes || echo DEBUG=no)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}