summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:01:39 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:01:39 +0000
commit29f27b47f68711c264eb5b662da4b6b96d20991d (patch)
tree1ad0d1d4bfb54f2c2a0ad078f401fb582cf158f9 /net-analyzer
parentCloses #7483. (diff)
downloadgentoo-2-29f27b47f68711c264eb5b662da4b6b96d20991d.tar.gz
gentoo-2-29f27b47f68711c264eb5b662da4b6b96d20991d.tar.bz2
gentoo-2-29f27b47f68711c264eb5b662da4b6b96d20991d.zip
Initial import.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ippl/ChangeLog8
-rw-r--r--net-analyzer/ippl/files/digest-ippl-1.4.141
-rw-r--r--net-analyzer/ippl/files/ippl.rc39
-rw-r--r--net-analyzer/ippl/ippl-1.4.14.ebuild32
4 files changed, 80 insertions, 0 deletions
diff --git a/net-analyzer/ippl/ChangeLog b/net-analyzer/ippl/ChangeLog
new file mode 100644
index 000000000000..b2677d4253ed
--- /dev/null
+++ b/net-analyzer/ippl/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/ippl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.1 2002/11/04 13:01:39 aliz Exp $
+
+*ippl-1.4.14 (04 Nov 2002)
+
+ 04 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuild contributed by Mike Lundy <novas007@gmx.net> in #8015.
diff --git a/net-analyzer/ippl/files/digest-ippl-1.4.14 b/net-analyzer/ippl/files/digest-ippl-1.4.14
new file mode 100644
index 000000000000..565816d81375
--- /dev/null
+++ b/net-analyzer/ippl/files/digest-ippl-1.4.14
@@ -0,0 +1 @@
+MD5 9abd0f77e118c3ddf6805e2de73ed56a ippl-1.4.14.tar.gz 54030
diff --git a/net-analyzer/ippl/files/ippl.rc b/net-analyzer/ippl/files/ippl.rc
new file mode 100644
index 000000000000..6c848f86aa6b
--- /dev/null
+++ b/net-analyzer/ippl/files/ippl.rc
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/files/ippl.rc,v 1.1 2002/11/04 13:01:39 aliz Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/ippl.conf ]
+ then
+ eerror "Please create /etc/ippl.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+ ebegin "Starting ippl"
+ start-stop-daemon --start --quiet --pidfile /var/run/ippl.pid \
+ --startas /usr/sbin/ippl
+ eend $? "Failed to start ippl"
+}
+
+stop() {
+ ebegin "Stopping ippl"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ippl.pid
+ eend $? "Failed to stop ippl"
+
+ # clean stale pidfile
+ if [ -f /var/run/ippl.pid ]
+ then
+ rm -f /var/run/ippl.pid
+ fi
+}
+
+
diff --git a/net-analyzer/ippl/ippl-1.4.14.ebuild b/net-analyzer/ippl/ippl-1.4.14.ebuild
new file mode 100644
index 000000000000..5b47a2858003
--- /dev/null
+++ b/net-analyzer/ippl/ippl-1.4.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14.ebuild,v 1.1 2002/11/04 13:01:39 aliz Exp $
+
+DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
+HOMEPAGE="http://pltplp.net/ippl/"
+SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=yacc-1.9.1-r1 >=flex-2.5.4a-r4"
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ dosbin Source/ippl
+
+ insinto "/etc"
+ doins ippl.conf
+
+ doman Docs/ippl.8 Docs/ippl.conf.5
+
+ dodoc BUGS CREDITS HISTORY README TODO
+ newdoc ippl.conf ippl.conf-sample
+
+ exeinto "/etc/init.d"
+ newexe ${FILESDIR}/ippl.rc ippl
+}
+