summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-05-21 19:30:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-05-21 19:30:00 +0000
commit22585f4f5d2d4784f3bda2518bd5f9260fc653be (patch)
treed1c44b0e2467e17b999c1717e1ceb2a0b52ec75a /net-analyzer
parentAdd missing inheritance of eutils.eclass (diff)
downloadgentoo-2-22585f4f5d2d4784f3bda2518bd5f9260fc653be.tar.gz
gentoo-2-22585f4f5d2d4784f3bda2518bd5f9260fc653be.tar.bz2
gentoo-2-22585f4f5d2d4784f3bda2518bd5f9260fc653be.zip
Version bump to the new shiny.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog9
-rw-r--r--net-analyzer/nmap/nmap-6.00.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index e329c28c8f94..a240258fb6c7 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.249 2011/06/12 22:14:04 spock Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.250 2012/05/21 19:30:00 robbat2 Exp $
+
+*nmap-6.00 (21 May 2012)
+
+ 21 May 2012; Robin H. Johnson <robbat2@gentoo.org> +nmap-6.00.ebuild:
+ Version bump to the new shiny.
12 Jun 2011; Michał Januszewski <spock@gentoo.org> nmap-5.51.ebuild,
+files/nmap-5.51-su-to-zenmap-fix.patch:
diff --git a/net-analyzer/nmap/nmap-6.00.ebuild b/net-analyzer/nmap/nmap-6.00.ebuild
new file mode 100644
index 000000000000..a2021d27ae5d
--- /dev/null
+++ b/net-analyzer/nmap/nmap-6.00.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.00.ebuild,v 1.1 2012/05/21 19:30:00 robbat2 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit eutils flag-o-matic python
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://nmap.org/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ dev-libs/apr
+ gtk? ( >=x11-libs/gtk+-2.6:2
+ >=dev-python/pygtk-2.6
+ || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 )
+ )
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.75-include.patch
+ epatch "${FILESDIR}"/${PN}-4.75-nolua.patch
+ epatch "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+ epatch "${FILESDIR}"/${PN}-5.21-python.patch
+ epatch "${FILESDIR}"/${PN}-5.51-su-to-zenmap-fix.patch
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with lua liblua) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ emake makefile.dep
+ emake
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir="${EPREFIX}"/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}