summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-12-11 14:28:16 +0000
committerJeroen Roovers <jer@gentoo.org>2013-12-11 14:28:16 +0000
commitc719eba2c7a5755fe09854a703c97dd4bc8bcf5a (patch)
tree0c8818eb17d60773a0e093c282a67b95824d2381 /net-analyzer/wireshark
parentBump tasty to 0.5.2 (diff)
downloadgentoo-2-c719eba2c7a5755fe09854a703c97dd4bc8bcf5a.tar.gz
gentoo-2-c719eba2c7a5755fe09854a703c97dd4bc8bcf5a.tar.bz2
gentoo-2-c719eba2c7a5755fe09854a703c97dd4bc8bcf5a.zip
Possibly fix compile problems with x11-libs/gtk+3.10* (bug #491464).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.11.2-gtk-deprecated-warnings.patch23
-rw-r--r--net-analyzer/wireshark/wireshark-1.11.2.ebuild5
3 files changed, 31 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 22e261a9bf80..7c1ab2afd437 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.565 2013/11/19 02:30:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.566 2013/12/11 14:28:16 jer Exp $
+
+ 11 Dec 2013; Jeroen Roovers <jer@gentoo.org> wireshark-1.11.2.ebuild,
+ +files/wireshark-1.11.2-gtk-deprecated-warnings.patch:
+ Possibly fix compile problems with x11-libs/gtk+3.10* (bug #491464).
*wireshark-1.11.2 (19 Nov 2013)
diff --git a/net-analyzer/wireshark/files/wireshark-1.11.2-gtk-deprecated-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.11.2-gtk-deprecated-warnings.patch
new file mode 100644
index 000000000000..36770dad25d7
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.11.2-gtk-deprecated-warnings.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1479,20 +1479,6 @@
+ wireshark_man=""
+ fi
+
+-if test "$have_gtk" = "yes" ; then
+- # If we have GTK then add flags for it.
+-
+- CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
+- CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
+- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
+- CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
+- if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
+- # Enable GSEAL when building with GTK > 2.20
+- # (Versions prior to 2.22 lacked some necessary accessors.)
+- CPPFLAGS="-DGSEAL_ENABLE $CPPFLAGS"
+- fi
+-fi
+-
+ # XXX - Is this really necessary? When we build with both Gtk+ and Qt it works...
+ if test "$use_glib_cflags" = "true"; then
+ # Use GLIB_CFLAGS
diff --git a/net-analyzer/wireshark/wireshark-1.11.2.ebuild b/net-analyzer/wireshark/wireshark-1.11.2.ebuild
index 28fe4bbdbc17..b113f661d757 100644
--- a/net-analyzer/wireshark/wireshark-1.11.2.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.11.2.ebuild,v 1.1 2013/11/19 02:30:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.11.2.ebuild,v 1.2 2013/12/11 14:28:16 jer Exp $
EAPI=5
inherit autotools eutils fcaps user
@@ -86,7 +86,8 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
- "${FILESDIR}"/${PN}-1.11.0-oldlibs.patch
+ "${FILESDIR}"/${PN}-1.11.0-oldlibs.patch \
+ "${FILESDIR}"/${PN}-1.11.2-gtk-deprecated-warnings.patch
epatch_user