summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-12 11:50:18 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-12 11:50:18 +0000
commitfa40b194f48a542cbc64e07a45a48b6f75bc6822 (patch)
tree3f2d3dfd6f8b71c7f93cb083669460fb672381bc /net-analyzer/ttt
parentPruned old versions (diff)
downloadgentoo-2-fa40b194f48a542cbc64e07a45a48b6f75bc6822.tar.gz
gentoo-2-fa40b194f48a542cbc64e07a45a48b6f75bc6822.tar.bz2
gentoo-2-fa40b194f48a542cbc64e07a45a48b6f75bc6822.zip
Version bump for bug 87980; added gcc4 patch from debian which removes the icky requirements on using -Wwrite-strings -fwritable-strings.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/ttt')
-rw-r--r--net-analyzer/ttt/ChangeLog9
-rw-r--r--net-analyzer/ttt/Manifest21
-rw-r--r--net-analyzer/ttt/files/digest-ttt-1.8.11
-rw-r--r--net-analyzer/ttt/files/ttt-gcc4.diff22
-rw-r--r--net-analyzer/ttt/ttt-1.8.1.ebuild51
5 files changed, 89 insertions, 15 deletions
diff --git a/net-analyzer/ttt/ChangeLog b/net-analyzer/ttt/ChangeLog
index 76c7bd741a3b..5662a3cbf8a8 100644
--- a/net-analyzer/ttt/ChangeLog
+++ b/net-analyzer/ttt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ttt
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttt/ChangeLog,v 1.6 2005/01/29 05:12:52 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttt/ChangeLog,v 1.7 2005/04/12 11:50:18 ka0ttic Exp $
+
+*ttt-1.8.1 (12 Apr 2005)
+
+ 12 Apr 2005; Aaron Walker <ka0ttic@gentoo.org> +files/ttt-gcc4.diff,
+ +ttt-1.8.1.ebuild:
+ Version bump for bug 87980; added gcc4 patch from debian which removes the
+ icky requirements on using -Wwrite-strings -fwritable-strings.
29 Jan 2005; Daniel Black <dragonheart@gentoo.org> ttt-1.8.ebuild:
changed net-libs/libpcap depend to virtual/libcap
diff --git a/net-analyzer/ttt/Manifest b/net-analyzer/ttt/Manifest
index 5a09fac46fdd..e27962cc11b8 100644
--- a/net-analyzer/ttt/Manifest
+++ b/net-analyzer/ttt/Manifest
@@ -1,16 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 86e66d9f3cbbf29ab3195814b437a83f ChangeLog 828
-MD5 685a02ea9c7601ba2b8fb03fb5d1e1d4 metadata.xml 264
+MD5 cf75b019f4c8cfa36b97cfa7d2de0488 ttt-1.8.1.ebuild 1286
MD5 46ca343fdd4095fb1001eb37d4f02d1b ttt-1.8.ebuild 1114
-MD5 525b88bccd59588c935e7951ad328ffe files/digest-ttt-1.8 59
-MD5 31221ee949d56df92f0c8299be79fc64 files/ttt-1.8-linux-sll.patch 2203
+MD5 cf2c02e65dc97ee97ae9c5680ab3c2e2 ChangeLog 1089
+MD5 685a02ea9c7601ba2b8fb03fb5d1e1d4 metadata.xml 264
+MD5 ea183ebbe91882d8b994ad70cf0a0eca files/ttt-gcc4.diff 683
MD5 731900a46e4de27b97ffefca6b161c37 files/ttt-1.8-pcap.patch 297
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD4DBQFB+xtcmdTrptrqvGERAg7dAJ9Y8NZr/JUEcMkQqyivZ0UYV3G9zACYtnVP
-+oSPQuDOG5s5ITg3ps5VsQ==
-=DpiN
------END PGP SIGNATURE-----
+MD5 31221ee949d56df92f0c8299be79fc64 files/ttt-1.8-linux-sll.patch 2203
+MD5 525b88bccd59588c935e7951ad328ffe files/digest-ttt-1.8 59
+MD5 699a57dff753234cd7f51906bd1f3e31 files/digest-ttt-1.8.1 61
diff --git a/net-analyzer/ttt/files/digest-ttt-1.8.1 b/net-analyzer/ttt/files/digest-ttt-1.8.1
new file mode 100644
index 000000000000..223260ed5207
--- /dev/null
+++ b/net-analyzer/ttt/files/digest-ttt-1.8.1
@@ -0,0 +1 @@
+MD5 651ea8ad895bcbca66e53be1fda0a26c ttt-1.8.1.tar.gz 135067
diff --git a/net-analyzer/ttt/files/ttt-gcc4.diff b/net-analyzer/ttt/files/ttt-gcc4.diff
new file mode 100644
index 000000000000..46c08f60f283
--- /dev/null
+++ b/net-analyzer/ttt/files/ttt-gcc4.diff
@@ -0,0 +1,22 @@
+diff -urN ../tmp-orig/ttt-1.7/net_names.c ./net_names.c
+--- ../tmp-orig/ttt-1.7/net_names.c 2000-12-20 15:30:09.000000000 +0100
++++ ./net_names.c 2005-02-09 14:41:36.180046553 +0100
+@@ -158,6 +158,9 @@
+ return NULL;
+ }
+
++static char *inet6_ntoa(uint32_t *addr); /* should be replaced
++ by addr2ascii */
++
+ char *net_getname(long type, long *id)
+ {
+ char *buf, *name;
+@@ -258,8 +261,6 @@
+ case TTTTYPE_IPV6HOST:
+ {
+ u_long tmp[4];
+- static char *inet6_ntoa(u_long *addr); /* should be replaced
+- by addr2ascii */
+ if ((buf = malloc(sizeof("xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx")))
+ == NULL)
+ fatal_error("get_protoname: no memory\n");
diff --git a/net-analyzer/ttt/ttt-1.8.1.ebuild b/net-analyzer/ttt/ttt-1.8.1.ebuild
new file mode 100644
index 000000000000..1875e4c74f85
--- /dev/null
+++ b/net-analyzer/ttt/ttt-1.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttt/ttt-1.8.1.ebuild,v 1.1 2005/04/12 11:50:18 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Tele Traffic Taper (ttt) - Real-time Graphical Remote Traffic Monitor"
+SRC_URI="ftp://ftp.csl.sony.co.jp/pub/kjc/${P}.tar.gz"
+HOMEPAGE="http://www.csl.sony.co.jp/person/kjc/kjc/software.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/libc
+ virtual/x11
+ dev-lang/tcl
+ dev-lang/tk
+ >=dev-tcltk/blt-2.4
+ virtual/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep 'pcap_lookupnet.*const' /usr/include/pcap.h &>/dev/null && \
+ epatch ${FILESDIR}/${PN}-1.8-pcap.patch
+
+ epatch ${FILESDIR}/${PN}-1.8-linux-sll.patch
+
+ epatch ${FILESDIR}/${PN}-gcc4.diff
+ # remove -Wwrite-strings -fwritable-strings (naughty)
+ sed -i 's/\(GCCFLAGS="\).*\("\)/\1-Wall\2/' configure || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodoc README
+ dodir /usr/bin
+ dodir /usr/lib/ttt
+ dodir /usr/share/man/man1
+ einstall exec_prefix=${D}/usr install-man || die "make install failed"
+ prepall
+}