summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
commitf62937cab196d3ac4f1c7cfe48733508bddb8de2 (patch)
tree9c80a9ffcaeccd18f09aa3ded1da093c3a2bab7e /net-analyzer/tcpdump
parentrepoman'd (diff)
downloadgentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.gz
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.bz2
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.zip
repoman'd
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild41
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.7.1.ebuild43
2 files changed, 35 insertions, 49 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild b/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild
index 04f7d01da353..1f7dc0e1b087 100644
--- a/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild
@@ -1,21 +1,17 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild,v 1.3 2002/07/18 15:01:43 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.6.2-r1.ebuild,v 1.4 2002/07/18 23:22:51 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="A Tool for network monitoring and data acquisition"
-SRC_URI="http://www.tcpdump.org/release/${A}
- http://www.jp.tcpdump.org/release/${A}"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
HOMEPAGE="http://www.tcpdump.org/"
-DEPEND="virtual/glibc
- ssl? ( >=dev-libs/openssl-0.6.9 )
- >=net-libs/libpcap-0.6.2"
-
-RDEPEND="virtual/glibc
+DEPEND=">=net-libs/libpcap-0.6.2
ssl? ( >=dev-libs/openssl-0.6.9 )"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
@@ -28,21 +24,18 @@ src_unpack() {
}
src_compile() {
- local myconf
- if [ -z "`use ssl`" ] ; then
- myconf="--without-crypto"
- fi
- try ./configure --host=${CHOST} --prefix=/usr --enable-ipv6 $myconf
-#--disable-ipv6
- try make CCOPT="$CFLAGS"
-}
+ local myconf
+ use ssl || myconf="--without-crypto"
-src_install() {
- into /usr
- dobin tcpdump
- doman tcpdump.1
- dodoc README FILES VERSION CHANGES
+ econf \
+ --enable-ipv6 \
+ ${myconf} || die
+ make CCOPT="$CFLAGS" || die
}
-
-
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc README FILES VERSION CHANGES
+}
diff --git a/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
index 00b457d102be..22dca9998f99 100644
--- a/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
@@ -1,42 +1,35 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild,v 1.3 2002/07/18 15:01:43 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild,v 1.4 2002/07/18 23:22:51 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="A Tool for network monitoring and data acquisition"
-SRC_URI="http://www.tcpdump.org/release/${A}
- http://www.jp.tcpdump.org/release/${A}"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
HOMEPAGE="http://www.tcpdump.org/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
-DEPEND="virtual/glibc
- ssl? ( >=dev-libs/openssl-0.6.9 )
- >=net-libs/libpcap-0.6.1"
-
-RDEPEND="virtual/glibc
+DEPEND=">=net-libs/libpcap-0.6.1
ssl? ( >=dev-libs/openssl-0.6.9 )"
+
src_compile() {
- local myconf
- if [ -z "`use ssl`" ] ; then
- myconf="--without-crypto"
- fi
- try ./configure --host=${CHOST} --prefix=/usr --enable-ipv6 $myconf
-#--disable-ipv6
- try make CCOPT="$CFLAGS"
-}
+ local myconf
-src_install() {
- into /usr
- dobin tcpdump
- doman tcpdump.1
- dodoc *.awk
- dodoc README FILES VERSION CHANGES
+ use ssl || myconf="--without-crypto"
+ econf \
+ --enable-ipv6 \
+ ${myconf} || die
+ make CCOPT="$CFLAGS" || die
}
-
-
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES
+}