summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-06-25 19:45:21 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-06-25 19:45:21 +0000
commit684eb1af97c92b5883df0a2eb7c9534ec429863b (patch)
treebb871826fc8f3313e934a702f83895ff68c7d659 /net-analyzer/pnp4nagios
parentarm stable, bug #421995 (diff)
downloadgentoo-2-684eb1af97c92b5883df0a2eb7c9534ec429863b.tar.gz
gentoo-2-684eb1af97c92b5883df0a2eb7c9534ec429863b.tar.bz2
gentoo-2-684eb1af97c92b5883df0a2eb7c9534ec429863b.zip
fixed php deps and allowed icinga to be used instead of nagios
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog8
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.14-r1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index 4dc890ff55e1..15be45ca1eae 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.41 2012/06/18 10:36:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.42 2012/06/25 19:45:21 prometheanfire Exp $
+
+*pnp4nagios-0.6.14-r1 (25 Jun 2012)
+
+ 25 Jun 2012; Matthew Thode <prometheanfire@gentoo.org>
+ +pnp4nagios-0.6.14-r1.ebuild:
+ you can use icinga or nagios with pnp4nagios now, fixes bug #422711
18 Jun 2012; Agostino Sarubbo <ago@gentoo.org> -pnp4nagios-0.6.11.ebuild,
-pnp4nagios-0.6.7.ebuild:
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.14-r1.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.14-r1.ebuild
new file mode 100644
index 000000000000..ad5330407bd1
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.14-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.14-r1.ebuild,v 1.1 2012/06/25 19:45:21 prometheanfire Exp $
+
+EAPI="2"
+
+inherit depend.apache eutils
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/php[json,simplexml,zlib,xml,filter]
+ >=dev-lang/php-5.3
+ >=net-analyzer/rrdtool-1.2
+ || ( net-analyzer/nagios-core net-analyzer/icinga )"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ media-fonts/dejavu
+ apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --mandir=/usr/share/man \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-config || die "emake install failed"
+ doinitd "${FILESDIR}/npcd"
+ rm "${D}/usr/share/pnp/install.php"
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/98_pnp4nagios.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "Please make sure to enable URL rewriting in Apache or any other"
+ elog "webserver you're using, to get pnp4nagios running!"
+}