summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-10-15 10:01:30 +0000
committerEldad Zack <eldad@gentoo.org>2004-10-15 10:01:30 +0000
commit17c636e5f598cf5741069225b48f49dbb9d2af18 (patch)
tree95c922650ccb52a87a3e4272c983e9ab2cdbc9bb /net-analyzer/p0f
parentInitial ebuild provided by Michael Owen <mowen@costco.com> in bug #65542. (Ma... (diff)
downloadgentoo-2-17c636e5f598cf5741069225b48f49dbb9d2af18.tar.gz
gentoo-2-17c636e5f598cf5741069225b48f49dbb9d2af18.tar.bz2
gentoo-2-17c636e5f598cf5741069225b48f49dbb9d2af18.zip
Removed uncalled for #include <net/bpf.h>
Diffstat (limited to 'net-analyzer/p0f')
-rw-r--r--net-analyzer/p0f/ChangeLog7
-rw-r--r--net-analyzer/p0f/p0f-1.8.2.ebuild4
-rw-r--r--net-analyzer/p0f/p0f-2.0.2.ebuild5
-rw-r--r--net-analyzer/p0f/p0f-2.0.3.ebuild10
4 files changed, 16 insertions, 10 deletions
diff --git a/net-analyzer/p0f/ChangeLog b/net-analyzer/p0f/ChangeLog
index 82e6bc687e10..c7aa26f12541 100644
--- a/net-analyzer/p0f/ChangeLog
+++ b/net-analyzer/p0f/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/p0f
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.16 2004/08/06 13:56:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.17 2004/10/15 10:01:30 eldad Exp $
+
+ 15 Oct 2004; Eldad Zack <eldad@gentoo.org> p0f-1.8.2.ebuild,
+ p0f-2.0.2.ebuild, p0f-2.0.3.ebuild:
+ Removed uncalled for #include <net/bpf.h> in 1.8.2 and 2.0.2. Removed patch in
+ 2.0.3 in favor of sed. Closes #50094.
06 Aug 2004; Gustavo Zacarias <gustavoz@gentoo.org> p0f-2.0.3.ebuild:
Stable on sparc
diff --git a/net-analyzer/p0f/p0f-1.8.2.ebuild b/net-analyzer/p0f/p0f-1.8.2.ebuild
index 6189549a5461..4ad97a6af586 100644
--- a/net-analyzer/p0f/p0f-1.8.2.ebuild
+++ b/net-analyzer/p0f/p0f-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.14 2004/07/11 10:33:31 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.15 2004/10/15 10:01:30 eldad Exp $
inherit eutils
@@ -17,6 +17,8 @@ DEPEND="net-libs/libpcap"
src_compile() {
epatch ${FILESDIR}/${P}-makefile.patch
+ sed -e 's;#include <net/bpf.h>;;' -i p0f.c
+
cp ${FILESDIR}/${P}.rc p0f.rc
make || die
}
diff --git a/net-analyzer/p0f/p0f-2.0.2.ebuild b/net-analyzer/p0f/p0f-2.0.2.ebuild
index 2d19a6f84311..fcf79c041e15 100644
--- a/net-analyzer/p0f/p0f-2.0.2.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.6 2004/07/11 10:33:31 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.7 2004/10/15 10:01:30 eldad Exp $
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
# the p0f.tgz always resembles the latest version, trashing the digest md5sum then, discovered and fixed by gustavoz
@@ -18,6 +18,9 @@ src_compile () {
sed -i "s: /usr/sbin/: ../../image/usr/sbin/:g" ${WORKDIR}/p0f/mk/Linux
sed -i "s: /etc/p0f: ../../image/etc/p0f:g" ${WORKDIR}/p0f/mk/Linux
sed -i "s: /usr/man/man1/: ../../image/usr/man/man1/:g" ${WORKDIR}/p0f/mk/Linux
+
+ sed -e 's;#include <net/bpf.h>;;' -i p0f.c
+
make || die
}
diff --git a/net-analyzer/p0f/p0f-2.0.3.ebuild b/net-analyzer/p0f/p0f-2.0.3.ebuild
index c7101c47be3d..f6b68b481904 100644
--- a/net-analyzer/p0f/p0f-2.0.3.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.3.ebuild,v 1.8 2004/09/16 02:11:18 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.3.ebuild,v 1.9 2004/10/15 10:01:30 eldad Exp $
inherit eutils
@@ -17,13 +17,9 @@ S=${WORKDIR}/${PN}
DEPEND="net-libs/libpcap"
-src_unpack() {
- unpack ${A} ; cd ${S}
-
- epatch ${FILESDIR}/${P}-libpcap-include.patch
-}
-
src_compile() {
+ sed -e 's;#include <net/bpf.h>;;' -i p0f.c
+
make || die
}