summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-03-27 00:41:43 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-03-27 00:41:43 +0000
commitadf644b04de0de5f50b193668a2f0e3924fde50e (patch)
treeb5398f257c6c7534e710a0f980a372fda8117db2 /net-analyzer/nstats/nstats-0.4-r1.ebuild
parenttouchups (diff)
downloadgentoo-2-adf644b04de0de5f50b193668a2f0e3924fde50e.tar.gz
gentoo-2-adf644b04de0de5f50b193668a2f0e3924fde50e.tar.bz2
gentoo-2-adf644b04de0de5f50b193668a2f0e3924fde50e.zip
Fixed glibc 2.4 compatibility wrt bug #126743
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'net-analyzer/nstats/nstats-0.4-r1.ebuild')
-rw-r--r--net-analyzer/nstats/nstats-0.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/nstats/nstats-0.4-r1.ebuild b/net-analyzer/nstats/nstats-0.4-r1.ebuild
new file mode 100644
index 000000000000..1180be485b0f
--- /dev/null
+++ b/net-analyzer/nstats/nstats-0.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nstats/nstats-0.4-r1.ebuild,v 1.1 2006/03/27 00:41:43 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Displays statistics about ethernet traffic including protocol breakdown"
+SRC_URI="http://trash.net/~reeler/nstats/files/${P}.tar.gz"
+HOMEPAGE="http://trash.net/~reeler/nstats/"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~ppc sparc x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+
+src_unpack(){
+ unpack ${A}
+ #rename bmon to bmon.nstats to avoid conflict with net-analyzer/bmon
+ epatch ${FILESDIR}/${P}-makefile.patch
+ if has_version '>=sys-libs/glibc-2.4' ; then
+ epatch ${FILESDIR}/${P}-glibc24.patch
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc BUGS COPYING doc/TODO doc/ChangeLog
+}