summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-26 02:04:06 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-26 02:04:06 +0000
commitfb2bc6f54c6b1d8381f40de8d5ceec9c9a2f1087 (patch)
tree11cf68eff5f88c7228d705abd0ea746d1ffd51f7 /net-analyzer/netwox/netwox-5.6.0.ebuild
parentmoved to netwox (diff)
downloadgentoo-2-fb2bc6f54c6b1d8381f40de8d5ceec9c9a2f1087.tar.gz
gentoo-2-fb2bc6f54c6b1d8381f40de8d5ceec9c9a2f1087.tar.bz2
gentoo-2-fb2bc6f54c6b1d8381f40de8d5ceec9c9a2f1087.zip
move from lcrzoex #35158
Diffstat (limited to 'net-analyzer/netwox/netwox-5.6.0.ebuild')
-rw-r--r--net-analyzer/netwox/netwox-5.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/netwox/netwox-5.6.0.ebuild b/net-analyzer/netwox/netwox-5.6.0.ebuild
new file mode 100644
index 000000000000..6a594b3806ce
--- /dev/null
+++ b/net-analyzer/netwox/netwox-5.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/netwox-5.6.0.ebuild,v 1.1 2003/12/26 02:04:06 vapier Exp $
+
+DESCRIPTION="Toolbox of over 400 utilities for testing Ethernet/IP networks"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwox/"
+SRC_URI="http://www.laurentconstantin.com/common/netw/${PN}/download/v${PV/.*}/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+
+DEPEND="=net-libs/netwib-${PV}*"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ -e "s:-O2:${CFLAGS}:" \
+ genemake config.dat
+ ./genemake || die "problem creating Makefile"
+}
+
+src_compile() {
+ cd src
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ dodoc README.TXT doc/*.txt
+ cd src
+ make install DESTDIR=${D} || die
+}