summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-27 15:35:17 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-27 15:35:17 +0000
commit81e4464d004a65ed2c403d87d2bb8184ef82cdcf (patch)
tree1c8f6e1a968130f5c66d496cc978459c7637c0c9 /net-analyzer/netperf/netperf-2.6.0-r1.ebuild
parentgit snapshot 20120618, thix fix problems in osd area, reported bey johns@vdr-... (diff)
downloadgentoo-2-81e4464d004a65ed2c403d87d2bb8184ef82cdcf.tar.gz
gentoo-2-81e4464d004a65ed2c403d87d2bb8184ef82cdcf.tar.bz2
gentoo-2-81e4464d004a65ed2c403d87d2bb8184ef82cdcf.zip
Add support for SCTP performance tests by K. Sanborn (bug #436398).
(Portage version: 2.2.0_alpha133/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/netperf/netperf-2.6.0-r1.ebuild')
-rw-r--r--net-analyzer/netperf/netperf-2.6.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/netperf/netperf-2.6.0-r1.ebuild b/net-analyzer/netperf/netperf-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..154a25f51947
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.6.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.6.0-r1.ebuild,v 1.1 2012/09/27 15:35:17 jer Exp $
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
+SRC_URI="ftp://ftp.netperf.org/${PN}/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+SLOT="0"
+IUSE="sctp"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ sed -i src/netserver.c \
+ -e '/^#define DEBUG_LOG_FILE_DIR/s:"/tmp/":"/var/log/":' \
+ -e 's:sizeof(netperf_response) - 7:MAXSPECDATA:g' \
+ || die
+
+ epatch "${FILESDIR}"/${PN}-fix-scripts.patch
+
+ # Fixing paths in scripts
+ sed -i -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script
+
+ # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
+ # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
+ append-cppflags -D_GNU_SOURCE
+}
+
+src_configure() {
+ econf \
+ $(use_enable sctp)
+}
+
+src_install () {
+ default
+
+ # move netserver into sbin as we had it before 2.4 was released with its
+ # autoconf goodness
+ dodir /usr/sbin
+ mv "${D}"/usr/{bin,sbin}/netserver || die
+
+ # init.d / conf.d
+ newinitd "${FILESDIR}"/${PN}-2.2-init netperf
+ newconfd "${FILESDIR}"/${PN}-2.2-conf netperf
+
+ # documentation and example scripts
+ dodoc AUTHORS ChangeLog NEWS README Release_Notes
+ dodir /usr/share/doc/${PF}/examples
+ #Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples
+}